lua error using warlock..

hello i get this message on my warlock…
terribly sorry if its long… update elvui already…
seems the HP is running a problem??

Message: Interface\AddOns\GS-HighPerformanceMacros\loaded.lua:24: attempt to call global ‘GSImportMacroCollection’ (a nil value)
Time: 11/02/16 00:22:16
Count: 1
Stack: Interface\AddOns\GS-HighPerformanceMacros\loaded.lua:24: in main chunk
[C]: in function `LoadAddOn’
Interface\AddOns\GS-Core\startup.lua:556: in main chunk

etc… kinda long

Unsure of the actual problem or if this is indeed a fix but someone commented earlier they resolved the issue after the update by changing the line 1st ilne back to: local Sequences = GSMasterSequences

The Just released HP Macros depends on GS-E 1.5 which took longer to get out of Beta than plannned. Last minute show stopper delayed this. Apologies for the inconvenience.

sorry for another post… i updated GSE and now i get a new message
Message: Interface\AddOns\GS-HighPerformanceMacros\loaded.lua:34: bad argument #1 to ‘pairs’ (table expected, got nil)
Time: 11/02/16 08:21:10
Count: 1
Stack: [C]: in function pairs' Interface\AddOns\GS-HighPerformanceMacros\loaded.lua:34: in function <Interface\AddOns\GS-HighPerformanceMacros\loaded.lua:26> [string "safecall Dispatcher[1]"]:4: in function <[string "safecall Dispatcher[1]"]:4> [C]: ? [string "safecall Dispatcher[1]"]:13: in function?’
…ore\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:90: in function `SendMessage’
Interface\AddOns\GS-Core\Core.lua:424: in function <Interface\AddOns\GS-Core\Core.lua:386>
Interface\AddOns\GS-Core\Core.lua:463: in function <Interface\AddOns\GS-Core\Core.lua:448>

Locals: <none>

i uninstalled GS-HighPerformanceMacros and it solved the problem
is there a way to import HP manually?? ty
can’t really play without gSE =p

same here please yhelp us , destro warlock

Hi Mike

Have you tried the import copy and paste to see if that will import the macro you are wanting to use? Copy your macro from the HP macro folder and then paste the macro in the Macro collection to import box and then click import below the box?

Then if it works you can go to /macro interface and set the icon to what ever you want.

The below Macro imported correctly and this one I manually imported by copying it out of the HP macro folder.I currently do not have the HP macros addon active.

Sequences['HP_EX_Demo'] = {
  Help='Single Target - This macro tries to hit the targets every Demonologist should be aiming for: Soul Shard generation for maximum Wild Imps uptime, DreadStalkers on CD, and plenty of Demonic Empowerment.',
  MacroVersions = {
    [1] = {
        "/targetenemy [noharm][dead]",
        "/cast [nopet][target=pet, dead] Summon Felguard",
        "/use [mod:alt] Drain Life",
        "/castsequence  reset=target  Doom, null"
      "/castsequence [nochanneling] Demonbolt, Call Dreadstalkers, Demonic Empowerment, Life Tap",
      "/castsequence [nochanneling] Demonbolt, Hand of Gul'dan, Demonic Empowerment",
      "/castsequence [nochanneling] Summon Doomguard, Demonic Empowerment",
      "/castsequence [nochanneling] Demonbolt, Hand of Gul'dan, Thal'kiel's Consumption",
      "/cast [nochanneling] Command Demon",
      "/cast [nochanneling] Demonbolt",