Macro stops working when i add variable

I am having issues getting this macro to work. I am playing with an xbox controller using consoleport.

Preface: I’m brand new to WoW and Macros, hopefully this is just a noob mistake. When i use the macro it casts the variable but then cycles through the two spells without casting them. If i remove the variable then it’ll cast the two spells no problem. I’m not sure what i am missing. I used a similar macro on my warrior character and it worked great. It hasn’t worked since that.

I’m not sure the correct way to format this but the macro is a loop basically set up like this:

/cast Smite

/cast Mind Blast

Keypress: /cast Power Word: Shield

Thanks for helping!

Your variables create a “stack” of commands when mixed with the action. This stack is read from the top down by WoW. WoW will execute the first GCD ability it sees and ignore the rest.

Your stack looks like

Action 1:
/cast Power Word:Shield
/cast Smite

Action 2:
/cast Power Word: Shield
/cast Mindblast

You can review the stack by hitting Compile Template / this will show you the actual macro that results from your template.

Basically Smite and Mindblast are blocked by your PW:S as PW:S is the first thing it sees on the GCD. It doesn’t matter if PW:S is on cool-down itself. You can only try one GCD ability per action.

Ah okay, i’ve been reading a bunch of stuff about the GCD’s but wasn’t sure how it works in macros.

So the macro i used before looked like this:

/cast Thunderclap
/cast Overpower

/cast Thunderclap
/cast Mortal strike

Thunderclap being my keypress variable.

Do you know why this macro worked on my warrior? As far as i can tell they all have a cooldown. I feel that i am missing something.

Whilst each ability has its own cooldown and resource needs, there is a separate Global Cooldown. Most but not all abilities trigger this cooldown. This is separate to an individual spells cooldown. I don’t know enough about your warrior specifics but would suggest that Thunderclap may not be on the GCD if what you have described worked.

I’ll have to look into it, from what i read they all have a gcd of 1.5 sec. Thanks for all the help! It’s been bugging me trying to figure it out.