Macros have to be imported everytime i load into a dungeon

I was friendly informed to put my problem in a more specific way.

Everytime i import a macro, adjust the ms. Save it and load into a dungeon or other instance of the game… i have to reimport the macro again, to fully use it. I get no problem prompt or any bug message… i wish i could describe it more better.

Feel free to ask.

Thank you for youre time.

Have you put the Icon on your bars before you load in? if yes, does the Icon disappear? So you have to re-add to your bars? or does the macro completely delete from GSE so you have to Import it again, create Icon and add it back to your bars?

Are you manually Spamming or using a Auto key press like AHK or Razor Mouse?


1 Like

Hey ! , thx for youre reply.

No it doesnt it stays on the bars… but when i click it nothing happens, if i have joined a dungeon OR got out of it… til i import again. It doesnt even delete completely…when i import it again it replaces the old macro code. I checked the code, they are similiar… thats why im wondering. Nothing changed in the code… atleast what i can see.

I would delete all the MACROs that are stored in your in game Macro section (the blizzard one) as this is where GSE stores them. If this become to full up it can cause issues

Once you have deleted these, remove them all from GSE macro section too

Then restart, and try import again

Always make sure you are out of combat when importing or changing a macro


1 Like

This sounds perfect, i will try ! and i think it will work.

Thank you very much for your help :slight_smile: have a nice day.

Thank you Tony,

it worked very well, i had a lot of macros in there… i think they came from Azeroth auto pilot and mega macro addons… i deleted all and imported it new. Worked !

Thank yo my friend :slight_smile: