No Idea what to do!

I don’t know why but none of the macros are working for me.
They all used to work, never had any problems until I let my son play on my computer for a while, playing Wow.
Since then I’ve tried to recreate my wow experience and no joy, cannot get the macros to play.
I’ve renamed my cache, interface and WTF folders so that Blizzard can do a total re-install, then added GSE and still no joy. What gets me is there is nothing on the icon except the question mark, when before there was an icon for a spell or whatever.
Is there anywhere else I have to go or clean up so that they work? With my arthritis I need these macro’s to be able to play at least better then I can do myself!

What are you using to press the macro keys?

Just a simple key, actually the two button on top of the keyboard. Why?

So you just press the buttons manually?

I was checking to see if you used software to confirm it was working

lets start with the 1st question. is GSE still in your game?

No, I press manually, I have Arthritis but I can press the buttons as long as they’re not too far-spaced as in Ctrl and Alt, etc.
Yes, I have installed GSE but nothing else, no ElvUI nor Weak Auras.

do GSE show up when you type /gse ? In GSE, you can go to options and try troubleshooting. What you explain that you dont see a icon is something I’ve seen before, but the macro worked even without icons showing. Have you tried at a target dummy to see if it works at all ?

Yes GSE shows up when I type /gse. I have been in the options to see if there’s anything that I could do specifically to make gse work. (Not that I needed to before)
When I target a dummy with the left mouseclick and press the number two button, nothing happens. When I right click and press the number two button, it goes to the next icon(in this case, “Blur”, because I’m testing on a DemonHunter and using @Oak’s Havoc One Button macro), and then it stays on that icon.

So it toggles icons but doesn’t do anything?
Ie it shows blur but blur doesn’t fire off?

FYI you can also change the icon in the wow macro panel in game.

Rule number 1: start with the basics - RTFM (Read the F’ing Manual)

You may need to toggle/adjust this setting.

@ The_Number_2
Simply put, Yes. and why would I change the icon in the macro’s panel?

I have read parts of the manual, don’t understand much, that’s why I install macros (templates) that have already been tested.
Never had problems with GSE before, played all through Legion, BfA, Shadowlands, and DragonFlight without a hitch, then as stated in my first post my son played, not on my character but on one he created, without GSE, (I should state). When I tried to play afterwards I noticed that GSE wasn’t firing off as before. What could’ve caused this?

I have now completely deleted World of Warcraft retail and re-installed it so as to wipe out all saved variables, and still, GSE isn’t firing off as before.
Help!!! please.

i get this a lot
almost certainly a broken macro
grinds gse to a halt

i have only fixed by installing wtf and interface folders from backups i keep

hopefully you have this from not too long ago

**try to export or keep codes for your gse macros in text file in case you have to re-import them after a problem like this

hope this isnt it

lol that was going to be my next suggestion. your always on top of that link.

the templates you install, just cuz they are tested doesnt mean that the issue Tim attached the link to, isnt going to fix the issue. read it and try it. then let us know. if you need help with figureing out how to do it, let us know.

What gets me, I’ve been using GSE for quite a while now, thank you @TimothyLuke ! Never had problem’s like this, so why now?

have you tried re-naming them and re-running them?

Qestion, what key you press on Keyboard? No 1 key ?
If you manually press it might be your son has accidently changed the keybinding for that key. Check in keybindings if it is correct, i had this happen once when my daughter whent on my computer and she changed all my keybindings :slight_smile:

Blizzard’s Dragonflight UI changes seriously are a buggy piece of crap. Your UI can now only work on one mode and not the other. The symptom that your UI is on one mode and GSE is setup for the other is you click the button and nothing happens. GSE depends on the WoW macro /click command and how that command works is different completely for KeyUp and KeyDown. Once loaded GSE can listen for that setting to change but on load that setting is not always available so it goes with what it was last set to.

This setting is stored server side. Uninstalling and reinstalling just puts you back exactly where you were. Until you fix the problem you can uninstall and reinstall 1000000 times and nothing will change.

The common reasons for this to occur: Blizzard patched something and reset this setting, another mod was updated and changed this setting or the wind changed outside and the result is that this setting changed. It’s not something you have any control over but need to keep on top of.

The fix: set it to KeyUp and see if it’s the same. If so set it KeyDown.

If this doesn’t solve it then you need to identify what changed when your son played WoW. without that piece of information we can’t do a thing to help.

1 Like

Thank you, you should put it like this in the RTFM (Read the F’ing Manual)
Did as you said and it worked after the KeyDown command, again thank you all for your time and efforts to keep me playing properly again.