Seeing instant heal

as a Feral Druid I had an add-on that showed me an aura when I had an instant heal, with and green aura over my head, but they broke it:

– An Addon my Midna/Ramono

local active = false – here we store if the addon is active

local frame=CreateFrame(“FRAME”) – Create a frame for tracking units buffs
frame:SetScript(‘OnEvent’,function() – set a script for then the event occurs
local found=0 – here we store if we found predator’s swiftness
for i=1,40 do – loop through max 40 buffs
local ,,,,,,,,,,id=UnitAura(“Player”,i) – we only need the last agrument of UnitAura, which is spellID
if id==8936 then – 69369 = predators swiftness
SpellActivationOverlay_ShowOverlay(SpellActivationOverlayFrame,8936,“TEXTURES\SPELLACTIVATIONOVERLAYS\FURY_OF_STORMRAGE.BLP”,“TOP”,1,255,255,255,false,false) – show the overlay
found=1 – we found the spell, store it
if found==0 then SpellActivationOverlay_HideOverlays(SpellActivationOverlayFrame,8936) – if we didnt find the spell. remove the overlay (Yes it spams but does it matter :)? )

if UnitClass(“PLAYER”) == “Druid” then – if player is druid
frame:RegisterEvent(“UNIT_AURA”) – register when the buffs/debuffs of the player change
active = true

SLASH_TRACKPST1 = ‘/pst’ – slash command
function SlashCmdList.TRACKPST(msg, editbox) – slash command function
if active == true then
active = false
print(“Predator’s Swiftness Tracking now DISABLED!”)
frame:UnregisterEvent(“UNIT_AURA”) – unregister buff/debuff changes
SpellActivationOverlay_HideOverlays(SpellActivationOverlayFrame,8936) – Hide the alert if active
active = true
print(“Predator’s Swiftness Tracking now ENABLED!”)

Well the indentation vanish, but it should still be easy enough to follow. I tried removing one parameter from:

local _,_,_,_,_,_,_,_,_,id=UnitAura("Player",i) -- we only need the last agrument of UnitAura, which is spellID

and it almost worked, but it would show the aura when I cast it, not when i had instant heal…

I figured it out… My first fix was to change the spell ID number, but that did not work. Then I later found they removed one parameter from the UnitAura so I deleted on comma, but I forgot to restore the spellID so I was tracking the wrong spell. I figured it out while posting it to you guys…