Shadowstep will not work

Hi all,
After following all the tips in another thread to get the GS macros firing again, I cannot seem to get Shadowstep to work…a message shows on the screen saying “Invalid Target”

The original line is;
/castsequence [mod:alt, stance=1,2,3] reset=target Shadowstep, Garrote, Ambush, Cheap Shot, null

(and yes, I have Subterfuge selected in the Rogue Points matrix)

Not sure about the stance bit btw, I deleted it without making a copy and it’s been years since I first put it in.

I have tried removing the castsequence and just making it Shadowstep alone, I noticed the word ‘Shadowstep’ would stay white (even after changing it to the spell number) until I removed the reset=target bit, but still no good.

Any suggestions?

OK - so I created a tester sequence with just the one line in it;

/castsequence [mod:alt] reset=target Shadowstep, Garrote, Ambush, Cheap Shot, null

This did not work - still says Invalid Target


But then when I took out the [mod:alt] it worked fine.

All the alt/ctrl/shift mods I have in other sequences work fine, but it now seems to be an issue with using a modifier in a castsequence line?

Is anyone else having problems with this? Not necessarily Shadowstep, but having a modifier and castsequence not working?

Check your self cast settings.

Alt is probably set as you self cast modifier.


That was it! I never thought to check those settings as I’d been using alt as a mod for years with no issue. And it seems to have only changed on my rogue (so far)

Thank you.

1 Like