Shift modifier broken - SOLUTION

Hi all,

At some point today I went and updated Elvui and whatever else was in the queue on CurseForge (sorry, I didn’t pay attention which ones), but after that my shift modifier stopped working.

The only way I can get it to work now is Esc ==> Options ==> Action Bars then set the “Lock Action Bars” button to “None”

The default is Shift.

Surprise, surprise - if I change it to Alt for example, then my Alt-modifiers do not work.

Hope this helps someone.


This has been a problem for me since the launch of Dragonflight. Thanks for finally helping me solve this issue and I attached a screenshot to help visualize your solution.

1 Like

For me this occurred for the first time after 10.1 dropped. I tried your fix and it worked.

HOWEVER, every time I logged in it reverted back to locked with the shift key as the modifer for moving icons.

I located the culprit of it being swapped back every time. It was ELVUI
Under Actionbars if you have Lock Actionbars selected, there is a drop down that appears above that is preselected to SHIFT, so this needs changed too in order to fix the SHIFT modifier for macros


1 Like

Wow thanks! That was driving me crazy when it reverted after every reload or login!