Strange new problem

So this started happening last week before the patch. I have my macro set in an action bar, mouse is set to repeat the button click. I press the button on the mouse, the hotkey highlights and nothing…just auto attack. So I do it old fashion way and left click the icon…and nothing…more auto attacks. Now if I right-click the hotkey, it works.

Also tried using the keyboard shortcut and still does nothing.

I use Bartender4 and I also disabled it and used the basic UI. Still the same thing.

All my other hotkeys work, with the mouse or the keyboard. It is just whatever button I put the Macro on

Most likely the sequence contains invalid commands and cant compile.

But you canCheck the created macro in /macro to ensure its activating the correct GSE sequence, ive had it happen where creating a macro for sequence_1 would for some reason insert a call to sequence_7, and if i had deleted sequence_7 it would behave as you described.

It’s almost like this has never happened before: ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

1 Like