The /use toggle boxes not saving when changed

Look I maybe missing something extremely obvious. But I’'m having an issue with the toggle use boxes not saving or allowing me to change them. By the /use toggle boxes I mean the boxes you click on when editing a macro that are for instance Trinket 1 or Trinket 2.

Any ideas?

Same problem here.
Use->Trinket 1 and Trinket 2 not saving.

Hello,

I already have issued a report on Github about the /use options, have to wait for Timothy to take a look at it.

This is Timothy’s reply:

The problem is I can’t replicate their outcome. I can’t cause the behaviour they are seeing to occur.

It’s either something broken on their instance of that macro, or not understanding the difference between the gold and silver ticks (ie setting them to silver and not realising that their defaults are to use trinkets) or simply not waiting for the save function to have completed before reopening the editor.

For this last scenario GSE puts the save function into a queue that checks if you are in combat. It can’t update the macro if you are. If you make changes, get put in combat, hit save, then reopen the editor and edit the macro you will have the old macro and abort the save action.

TimothyLuke
https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues/557

That’s odd, I mean I can try and record the process. But I’ve tried disabling the trinket options in the option window, it doesn’t matter if I click all of the boxes to gold/silver/black, I’ve tried changing it - saving it - closing it and then logging out/exiting the game to see if that helps. I do run other addons, but I’ve disabled all other addons except GSE. I’ve even tried deleting macros and rebuilding them from screenshots. I make sure I’m well and truly out of combat before touching GSE editor.

Commenting here was sort of a last ditch attempt, luckily for the current trinket setup I have one gold and the other off so I’m just using a passive equip trinket in the bottom slot.

1 Like

I’m having the same problem. I tried disabling the trinket options in the option window, tired saving it…but it still wont work. I also tried to reinstalled it make new macros but same issue…

1 Like

Also having this problem.

has anyone found any solution to this? @TimothyLuke

Yup…same issue too. I now can’t modify the Macros I import from here to suit my preferences. Was there a recent update? @TimothyLuke

Tim has corrected the issue on GSE_2.4.09, closing this topic.