These settings worked for me in the default macros for Dragon Flight

below is the image of my macro sequence firing and the options I used. It works on most of the default macros from curseforge.

The tricky part is that you have to press escape and go into your macro menu and edit it to look like this:
/click [button:1] MACRO_NAME rightButton t

It works well in all of the one button macros that I’ve tried with the exception of evoker.
Good luck everyone and happy clicking!

1 Like

Evoker macros seem to be working fine with the update. The biggest change that has been effective is changing button 1 from left to right as I did above. I did a week of testing each class and Elfy’s macros seem to be working fine on these settings. If it isn’t working for you then:

  1. Clear key bindings in troubleshooting
  2. Update macro stubs in troubleshooting
  3. Uncheck then recheck ActionButtonUseKeyDown
  4. Verify that force cvar is set to key down
  5. Type /macro into chat, open the macro and switch “Leftbutton” to “RightButton” and delete everything after the t. (your macro should look similar to the picture above)
  6. Hit save in the macro window
  7. Test the sequence on a target.
    The end result is that your macro should look like:

Hopefully this helps more of you out.

1 Like

This is wrong on so many levels and breaks a ton of things in GSE. Sure you may not be using them but this kind of advice causes more problems that I have to sort out than it prevents.

The underlying issue that you are hacking around is documented here: ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub