This is doing my head in!

Hey all,

In all of my melee macros I have the same pattern in the ‘Key Press’ section;

  1. the standard /targetenemy [noharm][dead] line,
  2. a mod:ctrl for a taunt of some kind,
  3. a mod:shift for an interrupt,
  4. a mod:alt for a charge.

So far this has worked a treat for me…I like to play several classes and having similar patterns helps.

But! This macro is not doing the interrupt or the taunt part. It’s the only one. I’ve deleted and re-written but still no good. Anything obvious that I’m missing?

Sequences['JD_BLOOD'] = {
-- This Sequence was exported from GSE 2.2.08.
  Talents = "2112132",
  MacroVersions = {
    [1] = {
      StepFunction = "Sequential",
        "/targetenemy [noharm][dead]",
        "/cast [mod:ctrl] Dark Command",
        "/cast [mod:shift] Mind Freeze",
        "/cast [mod:alt] Death Grip",
        "/cast [combat] Vampiric Blood",
        "/cast [combat] Dancing Rune Weapon",
        "/cast [nochanneling] Blood Boil",
        "/cast [@player] Death and Decay",
        "/castsequence [nochanneling] Marrowrend, Marrowrend, Blood Boil, Heart Strike",
        "/castsequence [nochanneling] Death Strike, Blood Boil, Heart Strike, Heart Strike",
        "/castsequence [nochanneling] Marrowrend, Heart Strike, Blood Boil, Heart Strike",
        "/cast Consumption",

Thanks in advance.

Could be a keyboard setting, a registry issue, or an ability that shares the same keybind; just need to hunt down the offending problem and fix it accordingly.

D’oh…this was it.

30+ characters and this DK was the only one that still had the shift and ctrl keybindings in place.

I’d just assumed they applied to all characters.