Troubleshooting Key Modifier Problems...

Macros that use Key Modifiers seem to cause troubles for some. In fact, it is the number one reported problem with the macros that I have shared on this site. As such, I thought it would be helpful if we had a “solutions page” for this type of issue.

The idea behind this thread is that people will share their solutions in this regard, in hopes of helping others in the future.

To start things off, here is a link to the most common solution (unbinding keys that use modifiers by default):

Cheers! ???

Windows 10 seems to react badly to multiple ctrl, shift or Alt keys, I keep getting pulled from the game by “sticky keys” message, it also stops the main marco from firing. As you can tell fighting a boss and you pop out of screen and marco stops, the DPS has a bad tenancy drop horribly. And ideas? Thanks.

I believe that the AutoHotKey program can help with the problem you have described.

Someone has even started an “AHK Help” thread on this site.

In fact, I use a “No Alt+Tab” script (noalttab.ahk) to prevent me from Alt Tabbing out of the game.

The script contains the following two lines of code:

; Disable Alt+Tab

I never had a problem with modifier in any macro. I could only imagine, that modifier in pre macro, that pressed to long causing the problem, by trying to cast a spell that is already used / dont have the resources for.

The problem i have, seems to be windows 10 specific. In fights where i press a combination of several keys, i get a windows overview of all processes that i have open (windows side by side). Thats pretty annoying - and any tipp would be welcome :slight_smile:

I would try the AutoHotKey program and create the NoAltTab script (mentioned above).

Sorry for the late response, I must have overlooked this.

Good luck! ???