Warmonger what better solution?

I’m having trouble creating my protection warrior macro, I can’t create a modifier macro that works.

I use the Warmonger feat.
But I was not successful, because the intercept is used when the charge is in progress. Bad result.

Then my solution would be to go to the key modifiers, I tried to use it this way, but it doesn’t work, when I hold the modifier key the macro stops running.

[“Variables”] = {
[“CHARGE”] = {
[1] = “/startattack”,
[2] = “/cast [nomod] Charge”,
[3] = “/cast [mod:shift] Shield Bash”,
[4] = “/cast [mod:ctrl] Intercept”
[“Actions”] = {
[1] = {
[1] = “/cast Heroic Throw”,
[“Type”] = “Action”
[2] = {
[1] = “CHARGE”,
[2] = “/cast Shield Block”,
[“Type”] = “Action”
[3] = {
[1] = “CHARGE”,
[2] = “/cast Shield Slam”,
[“Type”] = “Action”
[4] = {
[1] = “CHARGE”,
[2] = “/cast Trovoada”,
[“Type”] = “Action”
[5] = {
[1] = “CHARGE”,
[2] = “/cast Devastate”,
[3] = “/cast Shield Slam”,
[“Type”] = “Action”
[6] = {
[1] = “CHARGE”,
[2] = “/cast Revanche”,
[3] = “/cast Shield Slam”,
[“Type”] = “Action”
[7] = {
[1] = “CHARGE”,
[2] = “/cast [harm,nodead] Shockwave”,
[“Type”] = “Action”
[“InbuiltVariables”] = {
[“Combat”] = false,
[“Head”] = false,
[“Trinket1”] = true,
[“Trinket2”] = true,
[“Neck”] = false,
[“Ring2”] = false,
[“Belt”] = false,
[“Ring1”] = false

@Elfyau Dude, could you please give me some advice? or point out corrections?

is it possible to get some information on what the spell or feature is or how it works as I do not play WotLK

I use this talent in the protection talent tree:
Warbringer Rank 1
Requires Warrior (Protection)
Your Charge, Intercept and Intervene abilities are now usable while in combat and in any stance. In addition, your Intervene ability will remove all movement impairing effects.

Warbringer - Spell - WotLK Classic

However, I can’t use a modifier key (when I hold the modifier button, the macro crashes and doesn’t continue to spam the button), and I can’t use charge and intercept on the same button spam, if I leave it on the same button without modifiers when executing the charge the character executes the intercept in the middle of the charge execution and spends my rage and the intercept is CD.

I wanted to create a macro that when holding ALT it would use the intercept and if the target was an ally it would execute the Intervene:

10 Rage 8 - 25 yd range
Instant cast 30 sec cooldown
requires warrior
Requires level 70
Requires Defensive Stance
Run at high speed towards a party member, intercepting the next melee or ranged attack made against them as well as reducing their total threat by 10%.

Intervene - Spell - WotLK Classic

(without me skipping the spam button) just like I did before in macros in GSE 2.0

Another problem I have, when I hold the spam button (already with the button held down) I run the macro, and sometimes it uses Thunder Clap before reaching the target, spending my rage.

Overall I’ve tried several macro combinations, but nothing worked, currently I’m using intercept clicking with the mouse.

If you can’t help, I’ll thank you for answering me, and thank you for your free contributions to the GSE.

Ok, I am getting a little lost, so what works on the modifier keys?

Nothing, every time I try to use it it freezes the macro and nothing happens.
When I release the key the macro works (but without the modifier keys).

Maybe that’s what’s happening to me, but even though Timothy explains I can’t understand it, if you hear any more in-depth tutorials on this subject I’d really like to read it.

I also don’t know if the modifier keys have to be in the variable or I have to create some action block.

Gse can only try 1 spell per click. This is a WoW limitation. If you hold your mod key down and that spell is on cool-down or you don’t have enough mana etc it will block the rest of your macro till you release it as it’s continually trying to cast the spell from your mod key.

I’ve already researched the documentation on github, I’ve already caught other rotations here on the forum to copy the way other people make rotations, I’ve tested numerous combinations, but I haven’t been successful.

I kindly ask, what is the solution to my problem, I remember that in version 2.xx I imported some rotations here that behaved similarly to the result I’m looking for.
Pressing configured spam button. (X button)
x + shift = aoe skills
x+ alt = intercept
x+ ctrl = use interrupt skill

The solution is you need to think differently about what you are trying to achieve and look at it another way. You have asked why what you are doing is causing your macro to behave the way it is. You don’t like that and want me to somehow magically change how WoW behaves. I can’t. You need to rethink your approach and come at it a different way if you want a different result.

You have a very warlike way of talking, you always say “confront this or that”, you always assume that the person who is talking to you here on the forum is looking for facilities (I’ve seen it in other topics with the same position) from I will understand that the person is waiting for everything to magically fall from the sky, or that he runs away from hard work, sorry my friend, you don’t know me or know what I went through and go through, but that doesn’t give me the right to be harsh with anyone .

Have ways to talk to people, “be polite and kind to everyone around you”, my mother used to say, if you haven’t learned from hers, it’s never too late.

I’m fairly certain he wasn’t being as you described - he’s simply telling you that you have to look at this program or what you are trying to do from another viewpoint. Try not to take things so personally and perhaps it’ll help you in the end.

Completely random - have you checked your keybindings and that the keybinding is actually getting to the macro?

For example CTRL+n (where n is 1 to 0 and the - and = keys) is bound to the pet bar. If you haven’t removed this binding then the ctrl mod will never get to your macro. The same would apply to shift and alt. Keybindings take priority over macros.

And if I can’t tell what your issue is I can only guess as to the solution. Now either what you are trying is locking the macro and you need to try something different or in a different configuration or a different way or the keybinding is not getting through. From the information you have provided I can only speculate or guess.

This is not meant to be annoying or offensive but I just do not have anywhere near the information needed from what has been communicated to guess beyond that. Some things cannot be done the way you initially described it. You may need to do a lot of research into how [help] and [harm] work for your outcome. The best solution may be to put intercept and intervene on different buttons rather than on mod keys