WARNING!!!!!!!!!! DO NOT USE ANY MACRO CONTAINING /CONSOLE AUTOSHIFT

warning to all druids looking for easy instant healing touch from mangle procs do not use a macro wether it is a one button all in one dps including a heal proc autoshift in it ,u may get away with it for abit but sooner or later it will screw u server side.as it will lock your ability to free shift forms without manually cancelling ur current form…the only fix is to run this as a macro or as a / command in game…here is the fix /console autounshift 1 even a complete game reinstall will not fix u being locked out ffrom form shift after it has happened only fix as stated above is to run /console autounshift 1 …believe me i learnt the hard way…so plz makers of lazy wacros/gnome sequencer/gnome sequencer m macros do not include a procced self healing touch into a macro using the console autoshift commands wether it be in lua or plain txt… here is the culprit that got me screwed

#showtooltip Healing Touch
/console autounshift 0
/cast [@focus,exists,nodead][@player]!Healing Touch
/console autounshift 1
/cast Frenzied Regeneration

You mean after you have used a macro with this in it, say, when u want to mine you won’t go out of form automatically, so you always have to do it manually? like this… cause then i think i have the problem already :confused:

Tbh, I think the last tier talent where u become a different catform bugs the shifting. I had this talented and went back to bloodtalons, the problem is that i can still use all non damaging druid abilities while having my normal catform. It seems that the game is just still buggy itself since now i cant freely shift anymore…

Ok, i deleted all addons and wtf folder. Then removed wow. Fully installed again. Just a few basic addons i want and I dont know how but my problem is solved. Shifting seems to be fixed.

Tinfoil hat much ?

the problerm is the new talent not including a form, to solve the problem

  1. dont take the last talen
  2. we have to wait until blizzard fix the form.
  3. add Rejuvenation like /castseqquece reset=15 Rejuvenation in your macro.
    i use healing manually is binded on my mouse plus u have a new healing castable in cat/bear form,
    remove Healing Touch and add Rejuvenation like /castsequece reset=15 Rejuvenation in your macro.

This problem just started with me :frowning:

Has anyone managed to fix this issue? I just reinstalled the game, deleted WTF folder and removed all addons and still have the problem.

Thanks in advance

[quote quote=19260]This problem just started with me :-(

Has anyone managed to fix this issue? I just reinstalled the game, deleted WTF folder and removed all addons and still have the problem.

Thanks in advance
[/quote]

NVM…Fixed. Tks

This is not, at all, a server-side bug. The first console command disables autounshifting for casting. If your macro hangs before it gets to the re-enabling section, then you will need to re-enable the autounshifting feature. This isn’t a bug, it’s working as designed, and it resides client-side, not server side.

With that said, there is a bug with Claws of Shirvallah that allows you to cast from form even after you’ve deselected the talent. This is being actively exploited in game, but can lead to a situation where your macro just has you spamming Healing Touch (since you can then cast it without autounshift being needed), and hopefully it will be fixed soon.

This is not, at all, a server-side bug. The first console command disables autounshifting for casting. If your macro hangs before it gets to the re-enabling section, then you will need to re-enable the autounshifting feature. This isn’t a bug, it’s working as designed, and it resides client-side, not server side.

How do you re-enable the autounshifting feature?

Yeah happened to me too.
Running a macro on my druid also disabled the auto shape shifting on my shammy too.

Type /run SetCVar(“autoUnshift”, 1)

Fixed it for me.

THANK YOU!

I copied and pasted “/console autounshift 1” into the text window and bingo! I get to change forms again without having to undo it.

I was wondering why all of the sudden I couldn’t change from cat to travel or whatever without having to leave cat form and then go to travel.

Works like a charm! It was such a pain in the rear I made a macro for it but now I can just do it with one keypunch instead of 3.

[quote quote=26796]THANK YOU!
I copied and pasted “/console autounshift 1” into the text window and bingo! I get to change forms again without having to undo it.
I was wondering why all of the sudden I couldn’t change from cat to travel or whatever without having to leave cat form and then go to travel.
Works like a charm! It was such a pain in the rear I made a macro for it but now I can just do it with one keypunch instead of 3.
[/quote]

fixed it for me, thank you so much!!!