Where can I find the PTR version of GSE?

I see some posts about testing in Shadowlands, just wondering where y’all actually found the version of GSE that will work in PTR/Shadowlands?

In the usual links


You can join discord too.

Clean your WTF and addons folder just in case lua errors / not loading.


1 Like

Thank you! I wasn’t sure whether I was finding the right links lol

also Twitch addon has it.

I strongly recommend NOT downloading the GItHub versions as they are Work in Progress. Meaning they are completely untested and vary from what is published to Curseforge/twitch. They are often missing translations and libraries which are part of the publish to curse process.

1 Like

apologies boss @TimothyLuke

Edited post :stuck_out_tongue_winking_eye:

That explains why people are getting their retail games broken - thank you wowinterface for not understanding that this is for 9.0 not 8.3.

Because if you installed GSE 2.5.11 or one of the previous alphas you needed to clear that folder to get alpha17 to work. The earlier versions had some issues.

so this doesnt work, tried the link john posted, no luck tried the wowinterface link vyn posted, no luck.
the GS interface won’t popup (lua errors)

I’ve deleted my WTF folder completely and started over numerous times… no luck… any idea why?

Dude seriously, delete your addons folder too bc its too obvious what its happening.


If you don’t install the right version … it won’t work. After that it won’t matter what version you attempt to install you have a corrupt GSE.lua file. If you don’t deal with that you are dead in the water.

I have answered this question 103 times in the last 24 hours. In each case people were installing the wrong version of GSE for PTR and then installing the right one. Except they had already broken things and kept thinking that if they installed the right version from somewhere else that would fix it.

How to get GSE to work on PTR:
1/ DO NOT USE TWITCH or DOWNLOAD from Github or wowinterface
2/ DOWNLOAd manually from Curseforge go to the GSE page and Choose All Files, Scroll PAST the versions that are listed in the top and look for GSE 2.6.01-beta2-shadowlands or better
3/ if it doesn’t work because you couldn’t pay attention to these simple instructions FIX THE MESS YOU CAUSED by assuming that some other magic would make stuff work — Remove the GSE.lua file from the WTF directory,

If you have no idea what the WTF Directory is or keep getting errors, then maybe testing GSE on PTR or Beta might not be for you.

GSE is still undergoing development to be ready for prepatch. It may come as a shock but these things take time and testing which means there will be errors. If you get a new error lodge it on GitHub. However if you get the same error that the thousands going before you have already gotten and don’t pay attention to the solution, writing on the forum “it won’t work” won’t magically solve your issue.

1 Like

Golden words.

The Master has spoken😜

hello everyone i noticed on the ptr using gse and new macros to test the classes that addon seems to work much better than bfa, cds are activated immediately as well as spell seems to be more trustworthy and precise, it’s something only i saw or you had this perception too? it’s really good and makes great. tested in plus with my main hunter bm and it’s really well done.

1 Like