9.01 DESTRO EASY MODE, Read plz

So this macro includes a wait function. for it to work, you have to import and create icons for both macros. Only the main macro is to be put on bars though


Usage Information

Shift for AOE

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.14.

Macro Version 1

Step Function: Priority

Pre Macro: Summon Infernal

KeyPress: Immolate, Summon Voidwalker, Summon Imp

Main Sequence: Rain of Fire, Immolate, Soul Fire, Chaos Bolt, Incinerate

KeyRelease: Contains various utility functions.

Post Macro: Singe Magic


Usage Information

Dont put this on a bar. Just make the Icon

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.06.

Macro Version 1

Step Function: Sequential

Main Sequence: Conflagrate

10/17/2020 5:46PM Fixed main macro. should work as intended now.

1 Like

I tried this Macro and worked very good solar for me, I just hit a dummy a few times, nothing intense yet as far as game play, but it went through the spells I use with no issue.

Thanks a heap :slight_smile:

Thanks! If you have any classes you want a macro made for give me a shout!

actually now its just hanging on C bolt and soul fire, no immolate and Incenirate.Conflag…ohh I jut read the above , ill try importing both

Can you do sub rogue if your up for a challenge lol

the macros as is wont ever chain the ADVANCE_CHARGE macro. You have it calling ADVANCE_CHARGES


Fixed. thanks for bringing that to my attention

Does not include Corruption, as in the spell Corruption that is now available under the warlock tab in the spell book

you are right about that. I did not include corruption. I did the rotation from the rotation guides on wowhead and icyveins. neither of those guides includes corruption. Therefore i didnt include it in my macro.

what are the current talents youre using with this and what essence?

This macro turns off my sound effects everytime I try it. That alone is too bothersome for me. I need to hear whats going on lol.

it’s not the macro, ifs your keybinds on wow itself. look for the one that disabled sound effects (alt+s)

there is an option in gse to disable sound errors. Make sure that is unchecked

Im lvl 13 with in dungeons and other, it just spamms immolate - granted its still top dps, but weird how it spams it…may be because my lvl, and i do have the secondary macro in. (every once and a while it does conflagrate, and chaos bolt)

Seems whenever I’ve added the macro, it looks good, has the sequence “Incinerate, Incinerate, Incinerate, Immolate” but if I close it and open the edit view again it has swapped the sequence to “Shadow bolt, Shadow bolt, Shadow bolt, Immolate”.

Changed it back to Incinerate and saved, but if I opened up the edit view again it had swapped it to shadow bolt again.
Talents I’m using: https://i.imgur.com/GaIqYPo.png

As someone else has asked, what are the talents currently being used for this macro?

it is an aio(all in one) macro. any talent combination will work.

Get the same issue, I have no keybind to alt+s, this is the only macro that kills the sound…
disable sound errors is a global setting and doesnt kill all sound, i run tonnes of these macros across numerous characters and have never had this issue.

What MS are you running this macro at??

CTRL+S turns sound on and of. Atleast for me. Not ALT+S
Best Regards