BM WoD Beta macros.

I am in WoD beta, and have been toying around with some hunter macros. This is what I have come up with so far, but I do not know how well the will work with today’s build. I will find out as soon as the beta servers come back up.

Note: the only working macro storage Addn the has been updated for beta is, KayrMacro - Advanced Macros and Expanded Storage. I find that I like it a lot better then my current ones on live. You can find in on both Curse and Wowinterface. Here is the link on Wowinterface:

http://www.wowinterface.com/downloads/info22888-KayrMacro-AdvancedMacrosandExpanded…html

BM AoE

#showtooltip 
/castsequence reset=0.3 0,0,0,0,0,!Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Multi-Shot,Cobra Shot,Cobra Shot,Multi-Shot,Cobra Shot,Cobra Shot,Multi-Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

BM Single

#Showtooltip 
/castsequence reset=0.5 0,0,0,0,0,Kill Command
/castsequence reset=0.5 0,0,0,0,Glaive toss
/castsequence reset=0.5 0,0,0,Focus Fire
/castsequence reset=0.5 0,0,Dire Beast
/castsequence reset=0.5 0,Cobra Shot
/castsequence reset=5 Arcane Shot,Cobra Shot,Cobra Shot,Arcane Shot,Cobra Shot,Cobra Shot,Arcane Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

Pet Burst:

#showtooltip Stampede
/castsequence reset=0.3 0,0,0,Bestial Wrath
/castsequence reset=0.3 0,0,Stampede
/castsequence reset=0.3 0,!Intimidation
/castsequence reset=0.3 !Dire Beast 
/petattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

Pet attack with grow controll

#showtooltip
/petattack
/cast Charge
/petautocastoff [group] Growl
/petautocaston

Currently stampede Has been disabled, until Blizzard can fix some issues with it so In the meantime I have switched to ‘amurder of crows.’ however it does not work very well with the ‘Pet Burst’ macro. So I have had to make the following adjustments to it. However A Murder of Crow are not firing off, as it should. any suggestions on this would be greatly appreciated.

#showtooltip
/castsequence A Murder of Crows
/cast Bestial Wrath
/cast Intimidation
/cast Dire Beast
/petattack

Also charge/dash no longer works with my ‘Pet attack with grow control’ macro, so I had to make the following adjustments to it:

#showtooltip
/petattack
/petautocastoff [group] Growl
/petautocaston [nogroup] growl
/petautocastoff [nogroup] Cower
/petautocaston [group] Cower

As for my single and AoE shot rotation macros; They do a lot of damage, but Arcane shot and multi-shot are not firing off as well as I would like, so I am open to any suggested improvements to them.

Ok with the changes in focus cost for Arcane shot, and Multi-shot, I am able to get more of each in my rotations. So I have adjusted my macro for single and AoE targets:

Single Target

#Showtooltip
/castsequence reset=0.5 0,0,0,0,0,Kill Command
/castsequence reset=0.5 0,0,0,0,Glaive toss
/castsequence reset=0.5 0,0,0,Focus Fire
/castsequence reset=0.5 0,0,!Dire Beast
/castsequence reset=0.5 0,Cobra Shot
/castsequence reset=5 Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

AoE

#showtooltip 
/castsequence reset=0.3 0,0,0,0,0,!Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Multi-Shot,Multi-Shot,Cobra Shot,Multi-Shot,Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/castsequence reset=23 Focus Fire
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

I cannot get the single target one to fire off Kill Command OR Glaive Toss.

And I am glad that you Enable SFX at the end, but you never Disabled SFX in your macro there.

PS: I am using the Latest Posted

I didn’t notice a problem with kill shot shooting at targets, and most mobs have been dying to fast, for me to notice in combat. (Fully upgraded tier 16 and warforged is way OP, in WoD, before level 100)

Try this instead:

#Showtooltip
/castsequence reset=0.5 0,0,0,0,0,!Kill Command
/castsequence reset=0.5 0,0,0,0,!Glaive toss
/castsequence reset=0.5 0,0,0,Focus Fire
/castsequence reset=0.5 0,0,!Dire Beast
/castsequence reset=0.5 0,Cobra Shot
/castsequence reset=5 Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/startattack

Thanks for pointing out Sound FX Part. I based this off of a very old Macro of mine and hadn’t realized I had cut off the disable SFX part. It is not really need, and I don’t really mind the SFX. So since it just complicates things a bit for a Beta macro; am just going to remove it.

I have made a few minor changes from my AoE one as well, as it is using too much focus in real combat.

#showtooltip 
/castsequence reset=0.3 0,0,0,0,0,!Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,!Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/castsequence reset=23 Focus Fire
/startattack

If you are still having issues with kill command, try tying into the pet burst macro instead.

The only tweak (I think) I made was to disable the sound effects at the start:

Single Target:

#Showtooltip
/console Sound_EnableSFX 0
/castsequence reset=0.5 0,0,0,0,0,!Kill Command
/castsequence reset=0.5 0,0,0,0,!Glaive toss
/castsequence reset=0.5 0,0,0,Focus Fire
/castsequence reset=0.5 0,0,!Dire Beast
/castsequence reset=0.5 0,Cobra Shot
/castsequence reset=5 Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Arcane Shot,Cobra Shot,Arcane Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/castsequence reset=23 Focus Fire
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

AOE:

#showtooltip 
/console Sound_EnableSFX 0
/castsequence reset=0.3 0,0,0,0,0,!Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Multi-Shot,Cobra Shot,Cobra Shot,Focus Fire
/cast !Dire Beast
/cast Bestial Wrath
/cast [combat] Kill Shot
/castsequence reset=23 Focus Fire
/startattack
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear()

Glaive Toss and Kill Command aren’t launching

Ok when that fix didn’t work very well. Kill command still wasn’t firing off, it worked ok yesterday but not today. I spent the last 3 hours working on it and the following is the best I have come up with. Note With it you still need to keep an eye on your cool downs, as as the timing is still a bit off.

Single target

#showtooltip
/castsequence reset=0.3 0,0,0,0,0,Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Kill Command,Arcane shot,Cobra Shot,Kill Shot,Arcane Shot,Cobra shot,Glaive Toss,cobra shot,Focus Fire
/cast Rapid Fire
/cast Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire
/startattack

AoE

#showtooltip
/castsequence reset=0.3 0,0,0,0,0,Kill Command
/castsequence reset=0.3 0,0,0,0,Multi-Shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Kill Command,Multi-Shot,Cobra Shot,Kill Shot,Multi-Shot,Cobra shot,Glaive Toss,cobra shot,Focus Fire
/cast Rapid Fire
/cast Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire
/startattack

Darn I messed that single target one up on the copy I posted above, and my computer crashed before I could edit it. Here is the correct one

#showtooltip
/castsequence reset=0.3 0,0,0,0,0,Kill Command
/castsequence reset=0.3 0,0,0,0,Arcane shot
/castsequence reset=0.3 0,0,0,Cobra Shot
/castsequence reset=0.3 0,0,Glaive Toss
/castsequence reset=0.3 0,Kill Shot
/castsequence reset=5 Kill Command,Arcane shot,Cobra Shot,Kill Shot,Arcane Shot,Cobra shot,Glaive Toss,cobra shot,Focus Fire
/cast Rapid Fire
/cast Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire
/startattack

Guess whose back :slight_smile:

Well I got my WoD invite today, and I decided to test these macros.

For some reason Kill Command just doesn’t fire off. I’ve tried it with multiple macros above.

Glaive Toss is the same. Almost never goes off.

Kill Shot is bugged I’m guessing.

The big issue is that the GCD has changed. On live you can fire Cobra Shot and queue up Dire Beast within the macro, you can’t do that on beta. What sucks is it will cast Dire Beast when your in the middle of a cast of Cobra Shot. Even with the Sound FX error code stopper, the error comes up all the time. Normally after that happens the macro just quits until you find another mob.

Suggestion - Remove Dire Beast and replace with Thrill of the Hunt. I’m not sure if this is a code bug or a Blizzard bug.

Just an FYI; I’ve sticked the topic for the future. Great resource.

Thank you

The main thing to remember this is beta, and things change from build to build. Server lag is terrible in beta, which greatly affects the timing. Also I haven’t found a good working beta, cool down count down timer addon yet. Due all of this it is a bit hard to pin down the timing of the cool downs, accurately until it goes live.

For the most part these macros work, however sometimes they will get “stuck” and stop firing off properly. When that happens hitting Cobra Shot will usually, get it back on track. The same thing happened with my MoP beta macros.

It dose appear that the AoE one with Multi-Shot works better then the single target one, with arcane Shot. Most likely due to the difference in cool downs.

I would have to agree, the MultiShot really seems to work well, just the single that keeps getting stuck.

The new one actually tossed some glaives… once or twice :smiley:

Sorry but I still cant get the “/castsequence reset=0.3 0,0,0,0,0,ability” to work, as far as I can tell the only portion of this macro that works is the /castsequence reset=5 and below. part it out and test for yourself.

also I think “<t6>” will also cast glaive toss.
If I’m wrong maybe its just me.

This latest build seems to hit Kill Shot better, and fires off the occasional Glaive Toss, but still misses a lot of Kill Commands.

Have you played with it any more? Happy to give it a try and feedback if you do :slight_smile:

Sorry my Hunter in beta, is stuck in a Flight Path loop glitch for the last day, so until it is fixed I can work on much. If it goes on for too long I will make a premade 90 hunter. Thank goodness for the one working macro storage addon.

Flight path loop leaving the Garrison? Every time i’ve been stuck, it’s resolved itself when i opened a bug report - help, submit bug report.

I had just realized I didn’t have my “custom lag” setting enabled… will be re-testing soon.

Jacked with it some more… seems to be dead on this build - it seems to go through for one pass, and then that’s it… not spammable.

#showtooltip
/castsequence reset=0.5 0,0,0,0,0,Kill Command
/castsequence reset=0.5 0,0,0,0,Arcane shot
/castsequence reset=0.5 0,0,0,Cobra Shot
/castsequence reset=0.5 0,0,<T6>
/castsequence reset=0.5 0,Kill Shot
/castsequence reset=5 Kill Command,Arcane Shot,Cobra Shot,Kill Shot,Arcane Shot,Cobra Shot,<T6>,Cobra Shot,Focus Fire
/cast Rapid Fire
/cast Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire

This is my most recent attempt BTW

I believe that the preceding 0’s thing is still broke. The only thing actually working in your macro is:

/castsequence reset=5 Kill Command,Arcane Shot,Cobra Shot,Kill Shot,Arcane Shot,Cobra Shot,<T6>,Cobra Shot,Focus Fire
/cast Rapid Fire
/cast Dire Beast
/cast Bestial Wrath
/castsequence reset=23 Focus Fire

Take away all the “0” castsequence lines out of your macro and it still works exactly the same. But if you take out what I posted, then nothing works.

Rapid fire has been removed from the game, so you might want to remove it from your macro, as it can gum things up a bit.