Can not get icon to move to the quickbar

Ok, this one is odd. GSE works fine on all my other toons. I can get it to import, edit, execute, mod keys… All of it. Except my DK. I load in with no macros on it, create the default ones and I can’t move the icon to my quick bar. I tried importing macros, same thing. I’ve tried disabling all my other addons, no change. I tried making a simple one and the issue is the same.

Any ideas?

Edit: Got the problem on my paladin just now. One imported macro had an icon of a book and all the rest had a “?”. The book can’t be picked up, but the rest can. Hmmm…

Edit 2: Found the issue. My game macro list was full. After I deleted all the unused ones, everything cleared up.

You can also turn on the option to overflow into account macros if you have more than 17 character macros.

1 Like

specifically what is this under… hate to sound dense… but i looked in options and didnt see anything like that worded there… thanks TL . appreciate all you do.

Look for “Use Global Account Macros” in the options

Exactly what @TimothyLuke stated - when your regular 17 macros gets filled - it won’t create a new icon for the macros. You either have to remove icons under the addon “Remove Icon” or use the global ones to access a larger stash.

Did Global Macros resolve your problems?

Just to clarify. Each character has 18 macro slots (this is a wow limit not GSE.). Each account then has 120 slots that are share across the account. GSE will use 17 of the 18 character ones without pausing but won’t use the last one. It also can spill over into the account macros but it won’t unless you tell it to.