Cant move when im in fight when i press my Macro key.

Last night when i entered a dungeon and started the fight i couldent move or press any key with the mouse when i was in fight and used my macro key , it was like it blocked out the mouse . Anyone now what that is or how too fix it ?
When i turned off GS it worked fine.

Next time include the macro you were using with class and spec so we can review this a little easier.

I think you may be tanking. If you are tanking you may be using gse auto trinket use as an option. You need to turn those options off while tanking, just the trinket ones.

Ahh Thanks alot and if i every need more help with anything i will be typing out class and spec , But you were right thanks alot :slight_smile:


same happened to me… am using Unholy DK, updated GSE with all updated game files, my mouse and keyboard are fine, i changed 3 different mouses and also external keyboard and same thing happened all the time…when i try to walk with mouse (both left+right pressed) and if pressing GSE macro bounded key i stop in place, as soon as i stop pressing the GSE macro button i can move again, but as soon as i press it again am blocked in place. Am using GSE macro from your page with proper talents. It all worked fine till 2 days ago. Now i am reinstalling game, thinking am the only one with problem, but as it seems its something wrong with GSE. As well when i turned GSE addon off it worked fine.

(Besides i dont know if it supposed to work with only pressing and hold the button down? that never worked for me… i have to press same button all the time for macro to work, which doesnt bother me, but beening blocked in place is very frustrating)

And as i read comment above, i am dps-ing and i have as well “use” trinket… you think that is the problem? Thank you!!

Any thoughts? Are you talking about those click-able option for head, ring, trinket options, that might be clicked/declicked at the right bottom part of “edit macro” page? Should those all be off?

Thanks a lot… DREX