Castsequence macros repeats certain spells instead of casting them in a sequence

Ive had this issue with GSE for a long time.

If i make a macro like

/castsequence Healing Wave, Chain Heal

Then it will often get stuck casting either of the spells. An example could be that it would cast Healing Wave, Chain Heal, Healing Wave, Chain Heal, Healing Wave, Healing Wave, Healing Wave, Healing Wave, Healing Wave, Healing Wave.

Another example would be a lock macro like

/castsequence reset=target Incinerate, Immolate, null
/cast Chaos Bolt
/castsequence reset=target Incinerate, Incinerate, Incinerate, Immolate

Then it can also get stuck even on the first line, i select a new target and then it goes Incinerate, Immolate, Immolate, Immolate, Immolate

In theory these macros should work no problem, but for some reason they just sometimes randomly repeat certain spells. Sometimes they repeat them once, other times until i stop pressing the macro.

If i make a macro with logitech gamingsoftware that presses 1 12 123 and place the 3 lines above in individual normal ingame macros then it executes the castsequences no problem, but when put in GSE, it bugs out.

Also the priority option with GSE doesnt seem to work a lot of the time. If i make a logitech macro as above which goes 1 12 123 1234 12345 etc. and place the individual abilities/macros on each number then it uses them in the priority flawlessly, but with GSE it doesnt. An example could be an Ele shaman macro like

/cast Flame Shock
/cast Earth Shock
/cast Lava Burst
/cast Lightning Bolt
/cast Frost Shock

In theory this macro should cast lightning bolt when standing still and only cast frost shock if you start moving, with the logitech method described above, that is how it works. But with GSE it will often skip over lightning bolt and cast frost shock, despite standing still.

I use an ms of 40 to repeat my macros. Ive tried a lot of different numbers though, doesnt change much.

Someone might ask, that if the logitech macros work so great, why dont i just use that? The answer is that when you get it to press 1 12 123 1234 12345 etc. and you spam the button like you might do in certain situations like aoe where you target swap a lot, then it lags like crazy. It also takes up a lot of buttons on the screen instead of just one.

1 Like

And you risk getting banned as you are severely breaking Blizzards TOS by using your Logitech solution like you are doing.

The answer to your first question - castsequence is broken and has been since they took it out in legions beta and put it back at the last minute. It may or may not work for you. There is nothing GSE can do about it.

Second question - if you run /gse debug it will tell you why or why not an ability in your rotation worked or didnt. PLease note: It cant evaluate a castsequence line so cant tell you where that is up to or what part of it was trying to be executed.

Third note: at an MS pf 40 you are clicking your macro at 25 times a sec. As the normal GCD is 1.5 seconds you are actually using a line from your macro every 36 times your macro clicks. Welcome to Random mode. If you want your macro to be a bit more sane, SLOW IT DOWN.

castsequence is like playing russian roulette. Eventually it will go bang and by that point its too late to ask why.

I got the same software as you, and im a properly veteran of it.

When you are doing a recorded keyboard ( or mouse macro ), the trick its to NOT do the sequential as IT IS.

Let GSE do that for you! & on your LGS macros just repeat ONCE the sequence of your key ( or combined keys ).

I told in a post not long ago, LGS ( not the GHUB ) has ghosthing capabilites other mouse brand softwares cannot.

OH! And never go below < 100 ms on EVERY CLASS never or you will be logout of the game for flooding text.