GSE 2.1

I have just finished the first Beta of GSE 2.1

There are mainly cosmetic and quality of life updates. The big update though is in the options there is now this screen:

This will allow you to create a combination that you can use to reset the macro you click on. You will notice that the Macro in /macros is now also a lot more complicated than it was.

The other Quality of Life change is:

This will automatically create the Icon for you in the /gs window. You can untick it to prevent this happening if you prefer.

The full list is :
2.1.0

  • Cannot expand code box (horizontally)… enhancement #212
  • 2.0.14 Typing “/gs help” or “/gs cleanorphans” Errors bug #241
  • When Importing via the GUI add a Tick Box to automatically create the Icon for this macro enhancement #250
  • Add Modifier options to reset a macro enhancement - #236
  • Change scope of button to gsebutton to prevent conflict with RaidAchievement enhancement #251
  • Remove Legacy Adaptor from GSE2.1 - Make available as a seperate download enhancement #249
  • Add Dungeon and Heroic Dungeon configuration options enhancement #240

Please raise any issues on GitHub so I can track them before releasing
https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues

1 Like

I have just updated via curse to the new 2.1 and now I cannot get a single macro to work? I am trying to go back to 2.0.14 but cannot seem to find it on curse anymore?

https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues/253

The issue you are getting in the Beta - if yhou go to options and turn on a combination for Macro Reset this error will go away.

2.0.14 is there - You may need to set Curse Client back to Release.

Beta 2:
2.1.0

  • Not setting a reset combination causes a LUA Error Bug #253

Beta 3:

  • TOC returns a nil version to Transmission. #255

Having an issue with the beta saving the correct versions for dungeon, heroic, … seems to have a mind of its own.

Hey Tim

Picked up a bug in 2.0.14 and dont know if it persists in the new beta’s but might be something to loog at.

When you have multiple versions and you click on 1 then 2 then 1 again the editor frame expands downwards and you have to /reload to make the frame reset its draw size.

It happened on a macro I wrote way back when that had 36 different versions so dont know if the amount of versions made a difference in this.

Just a FYI

Thanks

It’s something to do with the split window. Made a lot of progress with this in the beta- ie if you switch to config it will sanely allow you to resize the window.

Cool. Didn’t know if you were aware of it as it was specific to what I was doing at the time. Thanks for the efforts Tim.

I’m finding a problem that I am trying to trouble shoot. This is one of those problems that doesnt happen for me so I’m asking for more information.

Technical Stuff:
GSE creates a 1 pixel x 1 pixel hidden “button”. It programs this button with your GSE macro. When you “Create Icon” it creates an entry in you /macro list that clicks this button. This entry used to look like:

#showtooltip
/click macroname

This click command was limited to passing through left click only to the button. To do the reset key stuff up earlier, i needed this click command to pass through more information. for GSE 2.1 it now looks like:

#showtooltip
/click [button:2] macroname RightButton; [button:3] macroname MiddleButton; [button:4] macroname Button4; [button:5] macroname Button5; macroname

Test Cases
When you login it is supposed to update the old entries to the new entries. What I am looking for is cases where it doesn’t update at login.

  • ALso if it doesn't update can you still run the macro with the old macro set? (You wont be able to do the reset stuff but does it completely fail or does it degrade.)
  • If you create the macro manually using the new format does it then work>
  • if you manually do a /run GSE.UpdateMacroString() does it then work?
  • Can you Delete an Icon and Recreate it via the GUI and does it come new format?

Any infomration would be appreciated at https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues/258

Beta 4

  • Heroic not saving state in editor #263
  • Change Help on Export from “” to [[]] #260
  • Improve efficiency of Transmission enhancement #256

THere is another build on Curse but I have had a couple reports of this error:

1x [ADDON_ACTION_BLOCKED] AddOn 'GSE' tried to call the protected function 'EditMacro()'.
!BugGrabber\BugGrabber.lua:573: in function <!BugGrabber\BugGrabber.lua:573>
[C]: in function EditMacro' GSE\API\Storage.lua:732: in functionUpdateMacroString'
GSE\API\Events.lua:145: in function ?' ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0-6.lua:145: in function <...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:145> [string "safecall Dispatcher[2]"]:4: in function <[string "safecall Dispatcher[2]"]:4> [C]: ? [string "safecall Dispatcher[2]"]:13: in function?'
...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0-6.lua:90: in function Fire' Ace3\AceEvent-3.0\AceEvent-3.0-3.lua:120: in function <Ace3\AceEvent-3.0\AceEvent-3.0.lua:119> [C]: in functionLoadAddOn'
FrameXML\UIParent.lua:407: in function UIParentLoadAddOn' FrameXML\UIParent.lua:494: in functionAchievementFrame_LoadUI'
FrameXML\AlertFrames.lua:291: in function <FrameXML\AlertFrames.lua:276>

The problem I have is that it doesn’t happen for me and I cant seem to cause it. If anyone is getting this error would really appreciate knowing when it happens, where in the world yuou were and what you are doing at the time and if you can do anything to make it happen. This is literally the last thing stopping GSE 2.1.0 but I dont want to release it till its ready.

Beta 7 changes

  • I haven’t been able to fix the above error. What I have done instead is push this function to both a command line option via /gs updatemacrostrings and a button on the options screen.

This was release this morning via Curse.

The main change is for Resetting a macro while still in combat. To use this feature you need to go into the options and enable it.

Change list:
2.1.0

  • /gs updatemacrostrings and GUI options to update Macro Stubs for Macro Resets #294
  • TOC and Library Update for 7.2 #293
  • Localisation updates for #257
  • logic update to match StepFunction Assignment #276
  • Extra Unit Tests for #276
  • Heroic not saving state in editor #263
  • Change Help on Export from “” to [[]] #260
  • Improve efficiency of Transmission enhancement #256
  • TOC returns a nil version to Transmission. #255
  • Not setting a reset combination causes a LUA Error Bug #253
  • Cannot expand code box (horizontally)… enhancement #212
  • 2.0.14 Typing “/gs help” or “/gs cleanorphans” Errors bug #241
  • When Importing via the GUI add a Tick Box to automatically create the Icon for this macro enhancement #250
  • Add Modifier options to reset a macro enhancement - #236
  • Change scope of button to gsebutton to prevent conflict with RaidAchievement enhancement #251
  • Remove Legacy Adaptor from GSE2.1 - Make available as a seperate download enhancement #249
  • Add Dungeon and Heroic Dungeon configuration options enhancement #240

Note:
To make this work Macros in the /macro window will now look like:

#showtooltip
/click [button:2] SAM_Ret RightButton; [button:3] SAM_Ret MiddleButton; [button:4] SAM_Ret Button4; [button:5] SAM_Ret Button5; SAM_Ret

Since update getting multiple errors and no macros work. Clicking on options gives the error below

Date: 2017-04-22 17:27:06
ID: 5
Error occured in: Global
Count: 1
Message: …\AddOns\GSE\API\GUIFunctions.lua line 143:
GSE isn’t registed with AceConfigRegistry, unable to open config
Debug:
[C]: ?
…nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1801: Open()
GSE\API\GUIFunctions.lua:143: OpenOptionsPanel()
GSE\GUI\Viewer.lua:237:
GSE\GUI\Viewer.lua:237
(tail call): ?
[C]: ?
[string “safecall Dispatcher[4]”]:9:
[string “safecall Dispatcher[4]”]:5
(tail call): ?
Ace3\AceGUI-3.0\AceGUI-3.0.lua:314: Fire()
…dOns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:22:
…dOns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:19
Locals:
None
AddOns:
Swatter, v7.0.5 (<%codename%>)
NPCScanOverlay, v7.1.0.1
NPCScanOverlayBroker, v1.2.7
Ace3, v
AceGUI30SharedMediaWidgets, v
AdvancedInterfaceOptions, v1.1.3
AGP, vr40-release
Altoholic, vr178
AngryKeystones, v
Atlas, vv1.41.03
AtlasBurningCrusade, v1.39.00
AtlasCataclysm, v2017-04-14T9:45:17Z
AtlasClassicWoW, v1.39.00
AtlasClassOrderHalls, vv1.41.00
AtlasDungeonLocs, v1.39.00
AtlasLegion, vv1.41.03
AtlasMistsofPandaria, v1.39.00
AtlasOutdoorRaids, vv1.41.01
AtlasScenarios, v1.39.00
AtlasTransportation, v1.40.00
AtlasWarlordsofDraenor, v1.39.00
AtlasWorldEvents, v3.19
AtlasWrathoftheLichKing, v1.39.00
AtlasLoot, vv8.03.05
AtlasLootBurningCrusade, vv8.03.05
AtlasLootCataclysm, vv8.03.05
AtlasLootClassic, vv8.03.05
AtlasLootLegion, vv8.03.05
AtlasLootMistsofPandaria, vv8.03.05
AtlasLootWarlordsofDraenor, vv8.03.05
AtlasLootWrathoftheLichKing, vv8.03.05
AucAdvanced, v7.4.5714 (TasmanianThylacine)
AucFilterBasic, v7.4.5714 (TasmanianThylacine)
AucFilterOutlier, v7.4.5714.5459(7.4/embedded)
AucMatchUndercut, v7.4.5714.5585(7.4/embedded)
AucScanData, v7.4.5714 (TasmanianThylacine)
AucStatHistogram, v7.4.5714 (TasmanianThylacine)
AucStatiLevel, v7.4.5714 (TasmanianThylacine)
AucStatPurchased, v7.4.5714 (TasmanianThylacine)
AucStatSales, v7.4.5714.5598(7.4/embedded)
AucStatSimple, v7.4.5714 (TasmanianThylacine)
AucStatStdDev, v7.4.5714 (TasmanianThylacine)
AucStatWOWEcon, v7.4.5714.5613(7.4/embedded)
AucUtilAHWindowControl, v7.4.5714.5575(7.4/embedded)
AucUtilAppraiser, v7.4.5714.5704(7.4/embedded)
AucUtilAskPrice, v7.4.5714.5599(7.4/embedded)
AucUtilAutoMagic, v7.4.5714.5686(7.4/embedded)
AucUtilCompactUI, v7.4.5714.5694(7.4/embedded)
AucUtilEasyBuyout, v7.4.5714.5576(7.4/embedded)
AucUtilFixAH, v7.4.5714 (TasmanianThylacine)
AucUtilItemSuggest, v7.4.5714.5651(7.4/embedded)
AucUtilPriceLevel, v7.4.5714.5633(7.4/embedded)
AucUtilScanButton, v7.4.5714.5631(7.4/embedded)
AucUtilScanFinish, v7.4.5714.5588(7.4/embedded)
AucUtilScanProgress, v7.4.5714.4979(7.4/embedded)
AucUtilScanStart, v7.4.5714.5347(7.4/embedded)
AucUtilSearchUI, v7.4.5714.5710(7.4/embedded)
AucUtilSimpleAuction, v7.4.5714.5705(7.4/embedded)
AucUtilVendMarkup, v7.4.5714.4828(7.4/embedded)
Babylonian, v5.1.DEV.332(/embedded)
BagBrother, v
Bagnon, v7.1.1
BagnonConfig, v7.1.1
Bartender4, v4.7.7
CallbackHandler10, v
ClassTimer, v2.3.70200.1
Configator, v5.1.DEV.406(/embedded)
CTBuffMod, v7.0.3.0
CTCore, v7.0.3.0
CTLibrary, v7.0.3.0
CTMailMod, v7.0.3.0
cUrsoc, v7.0.3
DataStore, vr62
DataStoreAchievements, vr45
DataStoreAgenda, vr25
DataStoreAuctions, vr47
DataStoreCharacters, vr38
DataStoreContainers, vr55
DataStoreCrafts, vr76
DataStoreCurrencies, vr34
DataStoreGarrisons, vr20
DataStoreInventory, vr48
DataStoreMails, vr48
DataStorePets, vr41
DataStoreQuests, vr40
DataStoreReputations, vr39
DataStoreSpells, vr29
DataStoreStats, vr28
DataStoreTalents, vr58
DBMArchaeology, v
DBMCore, v7.2.4-3-gb53dc1a
DBMDefaultSkin, v
DBMInterrupts, v6.2.0
DBMLDB, v
DBMRaidLeadTools, v
DBMSpellTimers, v
DBMStatusBarTimers, v
deathclock, v3.0
DebugLib, v5.1.DEV.337(/embedded)
ErrorFilter, vv3.2
ExRT, v3855
ExtraActionButtonMover, v
FlashTaskBar, v
FollowerLocationInfo, v1.0-Release
GnomishVendorShrinker, v
GSE, v2100
GTFO, v4.42.10
GuildCheck, vv 2.4.9
HandyNotes, vv1.4.13
HandyNotesDraenorTreasures, v1.20a
HandyNotesDungeonLocations, v1.16
HandyNotesLegionRaresTreasures, v1.01b
HandyNotesLegionTownPortals, v0.0.1
HandyNotesLegionTreasures, v1
HandyNotesPandariaTreasures, v1.06
HandyNotesSuramarLocations, v0.0.1
HandyNotesSuramarTelemancy, v1
HandyNotesTimelessIsleChests, v1.17
HandyNotesTreasureHunter, v1
HandyNotesWitheredArmyTraining, v1
HandyNotesWitheredChests, v1.2
HereBeDragons10, v1.18-release
IskarAssist, v
LDBArtifact, vv1.6
LibAlts10, vr49
LibButtonGlow10, v1.2.7
LibCandyBar30, v
LibChatAnims, v
LibDBIcon10, v
LibDDI10, v
LibDualSpec10, vv1.13
LibDurability, v
LibExtraTip, v5.12.DEV.423(/embedded)
LibGroupInSpecT11, v1.2.1
LibLatency, v
LibMapData10, v1.0.0.31
LibPeriodicTable31, vv3.3.0.558
LibSharedMedia30, v3.0-97
LibSink20, v
LibStub, v
LibTextDump10, v7.0.3.2
LootRollMover, v3.6
MageNuggets, v5.5.6
MageNuggetsStatMonitor, v1.2.1
MarkingBar, v2.2.1
MasterPlanA, vA
MikScrollingBattleText, v5.7.147
MinimapButtonFrame, v3.1.10e
MinimapButtonFrameShapes, v2.1.0
MinimapButtonFrameSkinPack, v3.0.1b
MoveAnything, v16.1.7
NeedToKnow, v4.0.26
NomiCakes, v7.2.0.1
NPCScan, v7.1.0.5
Oilvl, v6.5.2
Omen, v3.1.12
OmniCC, v7.1.1
OmniCCConfig, v
oRA3, vv7.2.1
Outfitter, v5.19
Panda, v6.0.0.49
Pawn, v2.2.4
Prat30, vr1054
Prat30Libraries, v
premadefilter, v2.0.6
Quartz, v3.3.4
QuartzProcs, v3.49
QuestGuruSounds, v2.4.25
RangeDisplay, vv4.6.0
ReputationBars, v7.2.1
SavedInstances, v7.0.8
Scrap, v13.5
ScrapOptions, v13.5
ScrapSpotlight, v13.5
SellJunk, v3.0.15
SilverDragon, vv4.0.2
SilverDragonBurningCrusade, vv4.0.2
SilverDragonCataclysm, vv4.0.2
SilverDragonLegion, vv4.0.2
SilverDragonMists, vv4.0.2
SilverDragonVanilla, vv4.0.2
SilverDragonWarlords, vv4.0.2
SilverDragonWrath, vv4.0.2
Simulationcraft, v1.6.2
Skada, v1.6.6
SlideBar, v7.0.5 (<%codename%>)
SpeedyLoad, v2.2.2
StatWeightScore, v7.5.3
Stubby, v7.4.5714 (TasmanianThylacine)
TidyPlates, v6.18.11
TidyPlatesGraphite, v
TidyPlatesGrey, v
TidyPlatesNeon, v
TidyPlatesQuatre, v
TidyPlatesThreatPlates, v8.3.4
TidyPlatesHub, v
TidyPlatesWidgets, v
TipHelper, v5.12.DEV.405(/embedded)
TipTac, v16.10.27
TipTacItemRef, v16.10.27
TipTacTalents, v16.10.27
TomTom, vv70200-1.0.0
WeakAuras, v2.3.9
WorldQuestGroupFinder, v0.22.4
WorldQuestsList, v33
WorldQuestTracker, v
XLoot, v7.2-1
XLootFrame, v7.2-1
XLootGroup, v7.2-1
XLootMaster, v7.2-1
XLootMonitor, v7.2-1
ZPerl, v5.2.2
ZPerlArcaneBar, v
ZPerlParty, v
ZPerlPartyPet, v
ZPerlPlayer, v
ZPerlPlayerBuffs, v
ZPerlPlayerPet, v
ZPerlRaidAdmin, v
ZPerlRaidFrames, v
ZPerlRaidHelper, v
ZPerlRaidMonitor, v
ZPerlRaidPets, v
ZPerlTarget, v
ZPerlTargetTarget, v
BlizRuntimeLib_enUS v7.2.0.70200 <none>
(ck=18eb)

You have another error that is the cause and this is the symptom. Really need the main error but I would check your GSE.lua file in WTF for corrupt macros.

2017-04-22 17:38:59
ID: 4
Error occured in: Global
Count: 1
Message: …\AddOns\GSE\API\Storage.lua line 1055:
bad argument #1 to ‘pairs’ (table expected, got nil)
Debug:
[C]: pairs()
GSE\API\Storage.lua:1055: GetMacroResetImplementation()
GSE\API\Storage.lua:1075: PrepareOnClickImplementation()
GSE\API\Storage.lua:553: OOCUpdateSequence()
GSE\API\Events.lua:281: ?()
Ace3\AceTimer-3.0\AceTimer-3.0.lua:53:
Ace3\AceTimer-3.0\AceTimer-3.0.lua:48
Locals:
(*temporary) = nil
(*temporary) = “table expected, got nil”
= <function> defined =[C]:-1


…\AddOns\GSE\API\StringFunctions.lua line 46:
bad argument #1 to ‘gsub’ (string expected, got table)
Debug:
[C]: gsub()
GSE\API\StringFunctions.lua:46: UnEscapeString()
GSE\API\StringFunctions.lua:34: UnEscapeTable()
GSE\API\StringFunctions.lua:8: UnEscapeSequence()
GSE\API\Events.lua:111: ?()
…Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:145:
…Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:145
[string “safecall Dispatcher[2]”]:4:
[string “safecall Dispatcher[2]”]:4
[C]: ?
[string “safecall Dispatcher[2]”]:13: ?()
…Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:90: Fire()
Ace3\AceEvent-3.0\AceEvent-3.0.lua:120:
Ace3\AceEvent-3.0\AceEvent-3.0.lua:119


these are the errors that come up on login

Yep you have a corrupt macro - the details and fix for this is located here:
Cause of Inability to Open Options and Table expected got String errors

lol that goes to a 404 error screen

ok problem solved…was some global macros with same name but no code…thanks for the help

Hello,

I just updated to 2.1 via Curse (now Twitch) and no macro worked.

/GS opens the addon and the macros are there, but options gives an error and doesn’t open.

I also got a global error at first WoW start up after upgrading.

Got to “roll back” to be able to play so I’m back running 2

I’ll monitor this chat for a solution or upgrade.

Best Regards

Watch Reruns of WoW Lazy Macros Creator (Lutechi) Live @ 10PM EST