GSE Cycling but not casting

Worked for me! THANK YOU!!!

Hi, I did everything but nothing, if I give the command / console etcetc, it works, but when I close (no reload) the game and reopen nothing when I click the macro it fails, I also did what he posted " Timothyluke "same thing, the macro doesn’t start, it just moves, then if I give the command / console then it works, I downloaded version 3.1.15

Many thanks ! /console ActionButtonUseKeyDown 1 command was also the fix for me.

1 Like

This worked! thank :rofl:

Just in case if it can help you.
There is an other solution that work for me without changing the other things in the game.
You can simply erase “leftButton” in the macro and it’s working.
Like in this example :
/click [button:1] ELFFERALST LeftButton ; [button:2] ELFFERALST RightButton; [button:3] ELFFERALST MiddleButton; [button:4] ELFFERALST Button4; [button:5] ELFFERALST Button5; ELFFERALST

Or you could read something and understand what is going on.


Are we good and should I close this if you guys figured it out?

Or it’s still an evolving issue?

I would say it is not resolved, I tested the ActionButtonDown fix today on a fresh install, it did literally nothing. Not saying it didn’t fix issues for some people here, but also I’m with Tim on this in that this a broader issue with multiple fixes. Hence I wouldn’t say it’s closed. That said I’ve yet to try out Tim’s latest fix in 3.1.14. If that resolves it then yes, I would say you can close this out.

1 Like

I tried a few of the troubleshooting, this particular option did the trick for me. Thanks =)

Hey man, thanks so much for all your hard work. I have decided to become a patron and donate to you. I know every little bit helps. Once I get homeI will get you taken care of!

/console ActionButtonUseKeyDown 1 works great but downside is you need to type it in everytime you login. trying the other way with clear keybind etc but nothing worked for me

1 Like

If you are using Elvui, Elv unsets this on login.

You can either remove Elv, set this on login or read through and change how GSE is setup based on ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

strange thing happen this issue is no longer happening to me since yesterday I log with all my addons elvui included and the macros works with no problems I don’t have to do the troubleshooting or write the script in chat .

I think bliz fixed something.

ElvUI stopped changing the setting at login.


I can also confirm. I tried all suggestions from Tim and others. The only work that worked for me was the following line:

/console ActionButtonUseKeyDown 1

Works now! Thank god!! LOL

mate this isnt an issue anymore coz the problem was from elvui and it has been fixed.

You are my hero! I just signed up for your patreon.

Downloaded updated GSE today 10.0.2 also have the High Perf Macro Plugin 7.0.3

Had fixed the clicking but nothing running before this. Have done the stubs again and still cycling without clicking on spells. Not sure what to do at this point.

try making the macro stub look like this:

/click [button:1] MACRO_NAME rightButton t

Also make sure you have cvar keydown selected and action keydown box ticked. Just change MACRO_NAME to your macro’s name.

You should remove this. It hasn’t been maintained since mid legion and will only cause you problems.

You need to go back to this document and work through your UI. ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

Blizzard changed how this works as recently as the last patch and depending on what your other mods are doing and your UI choices you will need to configure GSE to work with that. Making random changes to “I just set x and it worked” won’t help you if you don’t know why making said change is doing anything. This isn’t a “try all the things” this is a case where you have to look at your environment and then make decisions about how GSE is going to operate.

1 Like