GSE issues after using the Send feature

So, today I was making a simple macro for my wife to use, when I tried to use the “Send” feature.
(2.5.11 version is what I see in game)

Obviously from the title, the send feature wouldn’t work, and now I can not save any macros I make on both my wife and my computers anymore.

GSE also usually reopens if you close the macro edit page, it no longer does it since I tried to send macros over (Related?)

Edit: I downloaded the github version and that seems to work, so the Twitch version just isn’t updated?

I’ve tried deleting the macro and reinstalling from twitch, I’ve tried deleting the WTF stuff, neither of which worked.

I can import macros, but I cannot edit them. (This is now wrong, I cannot import macros either.)

Ok 2 failures:

  1. you downloaded from GitHub instead of Curse. You downloaded dev/test code - Good luck with that on Retail.

  2. you didn’t read this: GSE2 Howto: Fix Unable to import macros.

Okay, so I “failed” because the github version worked for me?

Thats not the only problem. I couldn’t create macros, edit macros or anything. Since importing macros is only one of the few issues that occured, even if that were to work to allow me to import, why would using the share button break it? And why would that stop me from editing macros that are already there, or from making GSE reopen after editing a macro?

My issue is, that even after completely deleting the file in savedvariables, i still had the same issue.

Because if you have a broken macro all of the functions sending/saving/importing will be broken until you fix it.

Watch Reruns of WoW Lazy Macros Creator (Lutechi) Live @ 11PM EST