Is there a way to use both SHIFT and CTRL keys as modifiers

For example:

/cast [mod:RSHIFT] spell
/cast [mod:LSHIFT] spell

Trying to figure out how to add some more control to my macros

Best person to ask there would probably be @TimothyLuke. If i’m not mistaken, he wrote the addon, so he would know how many, and which, modifiers you can use.

It’s not GSE, its WOW. I experimented with my AHK script building to expand modifiers easily after I came back in Shadowlands (7 years off before that) to find that there was no difference in WOW between lshift/rshift/shift and the rest.

This post from the wow forums confirms that some change during SL beta wrecked it and it was never fixed.

That’s actually user error and not true.

There are three states for each mod. Alt which on En uS keyboards equates to both alt keys. For European keyboards it generally is the same but there are some quirks but sometimes could be left only. There is lalt and ralt which are left and right respectively.

The error here is that order matters

/cast [mod:alt] spell1; [mod:ralt] spell2

Spell 2 will never be cast as the any alt before it takes precedence For this to work you need a
/cast [mod:ralt] spell2; [mod:alt] spell1

Now you can combine alts and shift etc but again order matters

/cast [mod:alt] spell1; [mod:ctrlalt] spell2

Spell2 in this case will never fire as the alt before it has taken precedence so it needs to be

/cast [mod:ctrlalt] spell2; [mod:alt] spell1

Now also consider the vertical stack order in each action block. Top down first, then for each line it’s left to right. (This is why the Compiled Template button in the template editor is so important to see and solve problems)

/cast [mod:alt] spell 1
/cast [mod:ctrlalt] spell2
/cast [mod:ralt] spell3

The alt on line 1 takes precedence over the ones below it so it needs to be

/cast [mod:ctrlalt] spell2
/cast [mod:ralt] spell3
/cast [mod:alt] spell 1

1 Like

What order would you consider appropriate? For instance, all of these only use the Hearthstone, and never the Dalaran Hearthstone…

/cast [mod:lctrl] Hearthstone; [mod:rctrl] Dalaran Hearthstone
/cast [mod:rctrl] Hearthstone; [mod:lctrl] Dalaran Hearthstone
/cast [mod:lctrl] Hearthstone; [mod:ctrl] Dalaran Hearthstone
/cast [mod:rctrl] Hearthstone; [mod:ctrl] Dalaran Hearthstone
/cast [mod:lalt] Hearthstone; [mod:ralt] Dalaran Hearthstone
/cast [mod:ralt] Hearthstone; [mod:lalt] Dalaran Hearthstone
/cast [mod:lalt] Hearthstone; [mod:alt] Dalaran Hearthstone
/cast [mod:ralt] Hearthstone; [mod:alt] Dalaran Hearthstone
/cast [mod:lshift] Hearthstone; [mod:rshift] Dalaran Hearthstone
/cast [mod:rshift] Hearthstone; [mod:lshift] Dalaran Hearthstone
/cast [mod:lshift] Hearthstone; [mod:shift] Dalaran Hearthstone
/cast [mod:rshift] Hearthstone; [mod:shift] Dalaran Hearthstone

It depends a lot on exactly which client you are using and the context. Your keyboard + localisation of WoW’s client is a determinant factor. And yes Logitech vs Razor vs generic have differences as well as fRFR vs enUS vs deDE

As a rule I would go Right → Left → any as that’s the way WoW’s command processor works. But remember that left = any on some clients and keyboards.

There is a GSE setting which will report on which mods are active when you hit a macro in GSE’s mod debug options tab. Be careful here as this isn’t macro debug but GSE’s mod debug and it is a ton of spam to the chat window.

My example was completely free of GSE, just vanilla WoW macros. No software enhancements, run-of-the-mill enUS keyboard. And its an experience plenty of people on the WoW forums have shared since 9.0.2 beta.

I’m not arguing for a fix, I’m just pointing out to everyone else that cares to listen that we are limited to 8 key mod combinations when including [nomod], and to plan accordingly. Statements to the contrary over the last year and a half are wishful thinking.

I’ll start with a blue post, the rest are for reference:

Well they work for me. They aren’t a GSE thing but a WoW client thing,

I’ve used multiple systems and hardware with the same results.

I guess it’ll be a mystery like the other GSE communities. :rofl:

@Drake and that question I will never answer as there is a thing called ethics. Same reason I won’t setup my own site. I don’t promote here there and don’t promote the there’s here. This isn’t my website. It’s just one of the places I answer questions

1 Like

Hold on a minute.

Are you the only person in the world where those macros works? This is super weird. Are YOU sure you tried this on RETAIL?

Oh, I also tried these with only the regular Hearthstone activating:

/cast [mod:rshiftlctrl] Hearthstone; [mod:lshiftrctrl] Dalaran Hearthstone
/cast [mod:rshiftctrl] Hearthstone; [mod:lshiftctrl] Dalaran Hearthstone
/cast [mod:rctrllshift] Hearthstone; [mod:lctrlrshift] Dalaran Hearthstone
/cast [mod:rctrlshift] Hearthstone; [mod:lctrlshift] Dalaran Hearthstone

It’s probably my fault.

Rshift rctrl and ralt are fucking broken ok. They have been since sl prepatch. NO and ifs or buts.

It is broken, there’s nothing we can do about it.
TimothyLuke is wrong.

If I set my game language to deDE and change my windows keyboard to a euro keyboard layout - it works. If I change to enUS and use same keyboard layout in windows - it fails. If I change back to a us 104 key keyboard it works with enUS. If I change to a us 101 it fails. Like I said earlier if you play around with these combinations you may be able to find one that works for you. I haven’t played on a Mac for a while so can’t comment there. For me WoW is behaving if I get the right os setup.

All I can do is report what I am seeing.

What are theses codes even mean on a WINDOWS based pc.

Do you mean 104 as US-International QWERTY (00020409) according:

What i tested:
0x00000409 - US
0x00020409 - PTBR ABNT2
0x0000100c - FRENCH-SWISS

With 4 diferent keyboards.

It seems high unlikelly what you’re saying, it does seems like a weird april fool “Works for me” situation, similar to this: (PCGW Adding a New, Community-Driven Feature: "Works on My Machine" Ratings for Pending Issues - Announcements - PCGamingWiki PCGW Community)

Whats the macro you’re using?
What keyboard?
What operation system?
What language?

I tried with 9 users with diferent keyboards (French-Swiss, Portuguese, US, Chinese (Simplified), Japenese, German) and none of them is working.

Can you really confirm that its working and you’re not trolling?

I’m using a Razer chroma with Windows 11

  1. Open the Settings app.
  2. Go to the Time & language section.
  3. Click on the Language & region option.
  4. Under the Language section, select the pre-installed language pack and tap on the three-dot menu present beside it.
  5. Select Language options.
  6. Click on the Add a keyboard button.
  7. Choose the keyboard language from available ones to add a keyboard layout to the taskbar.

I am not trolling nor is this an April fools prank. There are a number of things like this in WoW that work for someone and not others for no reason. Castsequence is a prime example.

Aware of that:

What specific language and specific macro you’re using?

Are we really changing the Language of Windows just to get certain Keybinds to work…?
If not then it’s a moot point.

@Jefferson_Rubim I’d have to say hes hmm…NOT trolling, lol. GSE is his baby.

1 Like