I’ve been a long time user of GSE and macros on wowlazymacros and in the past I’ve edited some macros to fit my own play-style but never really attempted to make my own. Since returning to the game mid way through Dragonflight I’ve noticed the limited number of macro creators so I decided to create my own for personal use. This is my attempt at Assassination Rogue, feedback welcomed.







Thank you! Works perfect! If you have the patience to work on Outlaw, will love you forever hahaha <3

1 Like

Thanks for the feedback. I will see what I can do about Outlaw. The hard part is balancing the roll the dice timings and the pistol shot procs.

1 Like

Can you explain what you mean till last spell before NULL means? like how do i know?

If you look in the OPENER macro for the list of abilities in the castsequence you’ll notice that the last ability that will be cast before ‘null’ is ‘cloak of shadows’, so as soon as cloak of shadows is cast then you let go of the shift modifier. ‘null’ is simply in the macro to make sure the macro doesnt repeat back to the beginning.

1 Like

I am a noob here but to make it simpler for people to see when the “cloak of shadows” has been cast can a block not be placed to put a message in centre of screen to say something like “END OPENER”?
I know you will say its easy to see but people, me!, are a bit slow and will miss it.

You can set up a Weak Aura to do that for you or simply use the addon TellMeWhen and add Cloak of Shadows to the 4 squares and put them in the middle of your screen. There’s nothing I can add to the macro to achieve that from my end sorry.

Hello and thank you so much for your macros especially for the rogue. I really only play LFR raiding Im super casual so I rarely even turn on recount so I cant tell you much about the damage, but when I hold shift for the opener it works fine (seems like it does 1 rotation I still have 2 hits of thistle tea left) and then she stops building combos which would indicate that the opener is complete but she also hasnt casted cloak of shadows yet? It seems it hits the null without going through the full rotation but I’m not sure why. Anyway thank you ever so much for your time I hope you start a patreon or list your macros on curseforge I would really love to support your efforts.

I’m replying on my phone so I don’t have access to the macro itself for a bit. First of all thanks for the kind words and support, really makes me feel like what I’m doing isn’t for nothing. To address the issue of the opener, I think I know what you are describing and I ran into that issue myself. Is the issue happening on training dummies and not in actual LFR boss fights? If this is the case then you can try removing the ‘reset=combat’ line and see if that makes it run through properly. Technically when you vanish you are leaving combat so the macro is resetting back to the start.

Let me know if that helps at all. I’m still trying to diagnose the root cause of the problem.

Currently using a friends laptop so it may not be the best fix but I updated both the ST_ASS_LEGION and OPENER0. Should be working as intended now.

Not sure what is going on, OPENER0 does nothing, I tried clearing keybinds, tried with it on my bar, and off my bar, tried manually spamming it and still not firing off. The macro itself works, kinda… seems to be a lot of downtime where I have no energy, and no abilities are going off. I tried it at 50ms, 100ms, 150ms, pretty much the same result on all of them.
All that being said, rogue is only 410 as a rarely played alt, I would play him more if macros worked better for rogues. Thank you for your work, been using several of your other macros.

Things to check:

  1. In the main macro, does the line say /click [mod:shift] OPENER0
  2. Are you in stealth? Because if you are not in stealth and are standing far from the target, the shadowstep won’t cast.
  3. Are you holding shift?

If none of these things resolve the issue then check back in about 30mins because I am going to revise the opener macro and rebuild because of the issues that have been made aware to me.

Macro revised and updated. Please copy both the main ST macro and the OPENER as both have been edited.

The OPENER is now shorter with less downtime and shouldn’t reset on the target dummy after casting vanish. The main ST macro has had the name of the OPENER changed to match the OPENER macro name.

Ok, deleted old macro, imported new update, I think the issue was not being in stealth, however, I don’t think the OPENER is cycling all the way through? It never gets to cloak, which should be the last spell if I understand correctly? It casts some spells, then hangs for several seconds. I’ll try to get 4pc and work on my stats a bit, see if that helps, thank you again for your work.

Make sure you copy the talents listed in the macro when you open it. It could be that you don’t have the talent “Lightweight Shiv” and so you don’t have the 2nd charge of shiv that’s used in the OPENER.

Initially this was working in fact I was going to update it immediately with a success but tonight I tried my little girl and its behaving as it was before…maybe there was an update that reverted back to the previous even the ALT gets hung up. I’ll delete it and try again. Thank you so very much Edit: I forgot to change my speed back down to 100 ms so ive deleted everything and fixed speed ill report back…lol

1 Like

does this work in AOE situations or only pioson bomb procs

Only poison bomb procs for now. Might add an aoe/mythic+ macro later though.

So I should be clear i cant get the opener or the alt to work correctly but the base macro is fantastic…lol

I just ran LFR on my rogue using this macro and had no issues. So let’s do some troubleshooting to try and fix the issue. Try these things:

  1. Delete all versions of the macro and copy and paste them fresh from the original post.
  2. Check to see if your keybinds for ALT, CONTROL, SHIFT are set to default in the main menu options.
  3. Check to see if you have keybinded ALT/CONTROL/SHIFT+(whatever number you put this macro on), if so set back to default.
  4. Copy the talents I have listed and use only those talents. Any changes could cause the macro to not function correctly.
  5. The SHIFT OPENER isn’t a press once modifier. You must hold SHIFT down while the main macro is firing until Cloak of Shadows is used.
  6. The ALT modifier is also not a just tap modifier. You must hold down ALT until Death’s Mark is used.

If all these steps fail then the issue could be internal on your end or simply user error.