Hi all,
I am not sure what’s wrong or how to fix it …
BUt my GSE addon is not working .
I did a complete deletion of the addon and a complete fresh install of the addon from curseforge, with that said no matter what macro I import and with the talents listed for the macro noting and i mean nothing happens…not one spell is being cast like it should be…everthing was working fine a couple of days ago this just started today …
not sure what to do or how to solve this problem
thank you

From Siodar on another post:



thats probably because Tim put a new GSE out for his patreons. so now that message will pop up til you get the new GSE.

1 Like

no message pops up and I have version 3.1.53of it installed?

Perhaps you could read GSE’s documentation. This link is added to pretty much every second thread on this site yet somehow you couldn’t find it. ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

Let me guess what changed a couple of days ago. All your other mods were updated because of the patch and between that and Blizzard’s changes this setting was changed by one of them.


I currently Don’t use GSE as I am a healer, But my guild is having the same issue as this when they press there number 1 the GSE macro it works but then suddenly stops working and nothing works to fix it,

We have spent countless hours trying to fix this the only thing that works is pressing the Interact key before you enter combat but this only works for 1 pull and then breaks again, this happens on every class we have tried (Paladin) (Hunter) (Monk) Druid)

I did try this on my Prot Paladin and it works fine no problems, we tried it with 2 druids and only 1 of them had this problem we tried this with 2 hunters and both hunters had this problem but after using the Interact key once there’s was fine for a long while and then they had to do it again and it was fine for a long while keep repeating the cycle etc, but the other Hunter as the person who was also the druid can’t get that to work as it breaks every pull they do or break in the middle of a pull. And we tried 2 monks and only that 1 same persons as the hunters and druids never worked for them.

Basically 1 person can’t use GSE at all it keeps breaking every single pull or in the middle, and 1 person just presses the Interact key as a temporary fix, and the other 2 members of my guild me and 1 other don’t have this problem at all.

Every one but me uses the same UI same addons same settings and everything just different key binds. If anyone can find a fix or look into this all feedback is appreciated…

And for anyone wondering yes we are a 4 person guild who runs mythic keys!

Then you have a conflict in your UI. You need to identify and fix that then GSE will work. GSE doesn’t make any changes to your UI and if other mods change things or put your UI in a state that is different to the default then GSE won’t work.

I use the following mods:

  • Big Wigs / Little Wigs
  • GTFO
  • GSE
  • WeakAuras
  • MRT
  • MDT
  • Plater
  • Details

If you are using any of the following you are in for a World of hurt because of how they have to manipulate your UI to work with Dragonflights rules to be able to function:

  • ElvUI
  • Dominos
  • Bartender
  • any mod that replaces your action bars.

If you are using any of that second set … good luck. You are going to need it.

Okay we tried this and nothing changed as the only addon you mentioned that they are using is the (dominos) we tried it with just that turned off and all the mods turned off and either way It doesn’t work I don’t really think it’s a UI/Addon issue, as 3 of them have the same UI settings and addons and only 2 of them can’t use GSE but the other 1 can perfectly fine and I can to with a different UI or addons then they have.

This is a list of the current Mods they are using.

AFKS • AFK Screen
Aspect Of The Hunter
Better Fishing
Details! Damage Meter
GSE: HandyNotes
iP Mythic+ Timer
Kui Nameplates
Leatrix Plus
LS: Toasts
Macro Toolkit
Masque: Dominos Plugin
Shadowed Unit Frames
XIV_Databar Continued
You GotMail

This is a list of the current Mods I am are using.

Details! Damage Meter
Elvui WindTools
Keystone Tooltip
Raider.IO Mythic Plus
Speedy AutoLoot
Total RP 3

I have always used GSE with Elvui and I have never had a problem…

Welcome to Dragonflight. GSE and ElvUi havnt played well together since the expansion because of the manipulation of the ActionKeyButtonDown CVar. Hence why Dominos from your other list also doesn’t play well with GSE. Your only hope short of removing both those addons is to set in GSE options on the Troubleshooting tab that CVar to KeyUp mode and hope.

If you want GSE to work well and reliably it needs KeyDown mode which breaks parts of Elv and Domino’s. Personally I was a great fan of Elv with Windtools. It just became to flakey this xpac. I’d login and Elv would change that CVar to what it wanted at random points in time, Sometimes even between pulls and the entire UI would just break.

We tried this with no addons Just using GSE: and it still doesn’t work along with trying the key down mode and the troubleshooting in GSE and it’s all the same nothing fixes it for some weird reason.

We are just not going to use GSE for now as we tried everything we could for hours and nothings worked, we are grabbing guides from wowhead and going to learn are classes until GSE gets updated to see if that fixes it.

If you have any more Ideas or tips I could try I would be happy to test them all with my guildmates who are having theses issues…

I am unable to fix GSE by osmosis or telepathy and you are unable to tell me what’s wrong beyond “it doesn’t work”. I can’t tell you what is happening with your client that is breaking it. All I can do is point you at what is known. For me and many others it just works.

The information I need to troubleshoot something like this is listed on GSE’s support site (which is not this forum). Sign in to GitHub · GitHub

Let me read thru your posts and see if I missed anything It could be a mod issue like you said…

[updated] 7:42PM

It seems Dominos is making the Keydown setting get stuck in GSE, Turning off then on the Keydown setting works but Dominos makes it get stuck in the middle of combat by disabling dominos/all addons GSE still does not work but the Keydown is on just stuck,

After turning off all the addons you must turn off KeyDown turn it back on and then /reload and it seems to have fixed it!

End Results: Dominos Is making GSE KeyDown settings get stuck,