Pets and auto attack are pulling enemies that I don't want

I’ve been playing a BM hunter for years A friend recently turned me on to these macros and GSE using my tartarus. Not familiar with how to write or edit macros and not real confident with GSE except for importing macros from this site.
I’m loving this macro (Elfyau bm hunter )except I’m finding that enemies are targeted that we don’t want targeted and auto attack is pulling them or the pets. I do not know what to do about this. Even if I hit passive sometimes uto attack will fire at the enemy that’s targeted automatically.

As @Elfyau said?:

“There are 2 things you can do - 1) practice letting go of the macro just before the mob dies or 2) go into the macro and fine and remove the line /targetenemy”

1 Like

Don’t let pets or auto attacks ruin the experience.
You can add extra lines to the targetenemy sections to have more control over your pets, so it’s up to you.

These lines are helpful

/cleartarget [dead]
/stopattack [noexists]
/targetenemy [noharm][dead]
/petattack [pet,harm]
/petassist [pet,harm]
/petpassive [noharm]

Bottom 3 should be added to (at the least) all pet classes if you dont want your pet running to the end of a dungeon and pulling everything back to you

Kill a mob and it should clear your target and stop autoattacks, will bring your pet back to you in passive mode and won’t attack anything until you land the first shot, gives you time to rehit passive if you need to.


Those command still working? I thought Blizzard screwed them up when they added Automatic Smart Pet Turn Off Growl in Dungeon.

I remember back in the old days Hunter get called out or even Kicked out of group because they forgot to Turn Off Growl or Dimiss Pet when Jump Down a clip for Short Cut Route. That was Why the Term “ HUNTARD” came from. :love_you_gesture:

I have to test those functions line again.


1 Like

I wouldn’t rely on it. The less crap you have in a macro the smoother and more consistent your rotation and DPS will be.

Theoretically correct… a smooth macro is the macro with less complicated functionality.


I really appreciate the help from this group and how quickly I’ve been getting some answers. I don’t really know much about macros so I’m not sure which lines I should add / change and where in the text and how to do it using GSE?

depending on the macro. But usually in the KeyPress variable. Best to reach out to the creator of the macro to be sure.

They do still work, i use them on my Warlock.

These actions are not on the GCD so they have very little impact on the performance and the fact you’re spamming the key multiple times a second means they will all fire while you continue to do your actions, they won’t interfere with your macro :slight_smile:

1 Like

It’s the macro he has here for single target and AOE

I have them programmed into a razor Tartarus so I’m not spamming keys all the time. A friend helped me do that also lol. Hes the the one that got spoiled by these lol. I only hit one key for each 1 and it just doesn’t sting until I hit it again to turn it off. But even when I do that sometimes things are still targeted and my pets go chasing after them and it’s causing problems

GSE also has an option called “Require target to use” you can also turn this on and off from the minimap icon. Essentially unless you are actively targeting something your macro won’t fire.


I don’t have a Mini map icon I wish I did. I’m still very new to this application like I said. I really need to get this taken care of because I’m getting nervous about going into dungeons because I can’t catch them every time or untarget quickly enough

Go into options /character then check must have target to use problem solved


I have this problem since starting to use gse. I have learned to make sure my camera is positioned so that I cannot see other mobs if thats not possible I position my camera so that I am looking down blocking sight of mobs I dont want to actually pull. Its not full proof but it works.

I thought of that function in GSE Options, however someone said it didn’t work. If I not remember Wrong someone said that while back ago. Anyway, I will look into that function. Thank you for bringing out.


Quick and dirty fix, remove the /targetenemy line from what is normally the KeyPress variable.

You will have to manually click or tab your targets, and pets may still run off if you are not paying attention.

Mind to keep pets on passive, and maybe go get the Play Dead manual for emergencies. Also find your follow and passive keybinds.

If pets are a big part of your class, take some time and learn to be a good steward of them.

Where do I remove it from? I use GSC I don’t know how to check these macros and change or remove lines

And I do have play dead and fetch. I’m just really getting frustrated because I don’t know how to fix the macro or where to fix the macro . Since I do use GSE I don’t know where to look for this stuff.
Starting to do myth xeros with Guild and I really have to pay attention and we’ve still had a couple issues nothing major but I’ve got to be able to just do my thing and not worry about pulling shit lol

Which macro are you using?

DF or Classic?