Repair GSE for Shadowlands Beta

HOW-TO REPAIR GSE for use in Shadowlands Beta Testing

REQUIREMENTS:

NOTEPAD++
– this is the editor I use for the LUA file, it is simplely the best thing to use for this

Dowload Files:
api/AceGUI-3.0
– You want the current aplha version, at the time I’m writting this (08/09/2020) that is r1237-alpha

This is the location for the download file: api/AceGUI-3.0
https://www.wowace.com/projects/ace3/files/3007724

You will need to copy the files:
AceGUIContainer-Frame.lua
AceGUIWidget-DropDown.lua
AceGUIWidget-MultiLineEditBox.lua

from the dictory you extracted them in to:

…\World of Warcraft_beta_\Interface\Addons\GSE\Lib\AceGUI-3.0\widgets

dictory. (You need to use the File Explorer to find and copy those files to that directory)

YES, REPLACE THE FILES

Now that you copy over those files comes THE HARD AND DANGEROUS PART!!

Go to the dictory:

…\World of Warcraft_beta_\Interface\Addons\GSE\Lib\LibQTip-1.0

Find the file named:

LibQTip-1.0.lua

Now open this file up in Notepad++

Go to line number: 70

Change:

local highlightFrame = CreateFrame("Frame", nil, UIParent)

to

local highlightFrame = CreateFrame("Frame", nil, UIParent, BackdropTemplateMixin and "BackdropTemplate" or nil)

Go to line number: 171

Change:

local frame = tremove(frameHeap) or CreateFrame("Frame")

to

local frame = tremove(frameHeap) or CreateFrame("Frame", nil, UIParent, BackdropTemplateMixin and "BackdropTemplate" or nil)

Go to line number: 225

Change:

	cell = setmetatable(CreateFrame("Frame", nil, UIParent), self.cellMetatable)

to

	cell = setmetatable(CreateFrame("Frame", nil, UIParent, BackdropTemplateMixin and "BackdropTemplate" or nil), self.cellMetatable)

Go to line number: 364

Change:

	tooltip = CreateFrame("Frame", nil, UIParent)

to

	tooltip = CreateFrame("Frame", nil, UIParent, BackdropTemplateMixin and "BackdropTemplate" or nil)

Then do CNTRL+S and save the changes you’ve made

Close Notepad++
Start up BattleNet
Select the Shadowlands Beta
Click Play
Click on the AddOns button
Make sure that all the follow Addons are Checked
– GSE2: Gnome Sequencer Enhanced
– GSE2: GUI
– GSE2: LDB
Click Okay
Click Enter World

Gnome Sequencer Enhanced will work.

WARNING:

  1. I am neither a LUA programmer, nor a GSE expert, just a WoW player that loves this AddOns
  2. I have tested nothing beyond making it work, so I have not tried to Import, or Export, or create New Macros
1 Like

Thank you very much, it works, tested import/export.

Thanks a lot, seems to be working fine, except i get this error at times, but can’t find where it comes from.

Message: Interface\SharedXML\NineSlice.lua:75: Attempt to access forbidden object from code tainted by an AddOn
Time: Sun Aug 9 20:30:31 2020
Count: 1
Stack: Interface\SharedXML\NineSlice.lua:75: Attempt to access forbidden object from code tainted by an AddOn
[string “=[C]”]: in function CreateTexture' [string "@Interface\SharedXML\NineSlice.lua"]:75: in function <Interface\SharedXML\NineSlice.lua:63> [string "@Interface\SharedXML\NineSlice.lua"]:389: in function ApplyLayout’
[string “@Interface\SharedXML\Backdrop.lua”]:378: in function ApplyBackdrop' [string "@Interface\SharedXML\Backdrop.lua"]:212: in function OnBackdropLoaded’
[string “:OnLoad"]:1: in function <[string ":OnLoad”]:1>

Locals: (*temporary) = {
0 =
String = {
}
Tail = {
}
OnBackdropLoaded = defined @Interface\SharedXML\Backdrop.lua:205
GetBackdropColor = defined @Interface\SharedXML\Backdrop.lua:446
SetupTextureCoordinates = defined @Interface\SharedXML\Backdrop.lua:263
OnBackdropSizeChanged = defined @Interface\SharedXML\Backdrop.lua:235
HasBackdropInfo = defined @Interface\SharedXML\Backdrop.lua:327
SetBackdropBorderColor = defined @Interface\SharedXML\Backdrop.lua:478
inset = 16
GetEdgeSize = defined @Interface\SharedXML\Backdrop.lua:241
ApplyBackdrop = defined @Interface\SharedXML\Backdrop.lua:356
SetBackdrop = defined @Interface\SharedXML\Backdrop.lua:385
ClearBackdrop = defined @Interface\SharedXML\Backdrop.lua:331
GetBackdropBorderColor = defined @Interface\SharedXML\Backdrop.lua:465
GetBackdrop = defined @Interface\SharedXML\Backdrop.lua:403
SetupPieceVisuals = defined @Interface\SharedXML\Backdrop.lua:295
SetBackdropColor = defined @Interface\SharedXML\Backdrop.lua:455
backdropInfo = {
}
SetBorderBlendMode = defined @Interface\SharedXML\Backdrop.lua:315
}

This looks like a Blizzard problem, and from what I’ve been able to research on Google is:

“It seems that one requirement for this “blocked” message to show is that any of the addons you have active uses the new “BackdropTemplate” (that is: pretty much any addon with a UI).”

Which of course would be GSE as well. I’ll do more investigation.

1 Like

Ok, this is just me think out loud, and I would need to test this, but what would happen if you removed:

BackdropTemplate

from the following files:

AceGUIContainer-DropDownGroup.lua
AceGUIContainer-Frame.lua
AceGUIContainer-InlineGroup.lua
AceGUIContainer-TabGroup.lua
AceGUIContainer-TreeGroup.lua
AceGUIWidget-DropDown.lua
AceGUIWidget-Keybinding.lua
AceGUIWidget-MultiLineEditBox.lua
AceGUIWidget-Slider.lua
LibQTip-1.0.lua

that might cause more problems - but I’ll try and testing that some time later.

Please stop doing this - there is a GSE alpha for Shadowlands on Curse that has these and many more problems solved.

https://www.curseforge.com/wow/addons/gse-gnome-sequencer-enhanced-advanced-macros/files

2 Likes

i still had to do the first steps maarc posted on the released 9.0.1 gse for the ptr to get it to work correctly

Just sharing this here as I’m browsing a way to get it to work on PTR

Message: Interface\AddOns\GSE\API\Events.lua:372: attempt to call field ‘GUIShowViewer’ (a nil value)
Time: Tue Aug 11 18:57:18 2020
Count: 1
Stack: Interface\AddOns\GSE\API\Events.lua:372: attempt to call field ‘GUIShowViewer’ (a nil value)
[string “@Interface\AddOns\GSE\API\Events.lua”]:372: in function ?' [string "@Interface\AddOns\GSE\Lib\AceConsole-3.0\AceConsole-3.0.lua"]:94: in function ?’
[string “@Interface\FrameXML\ChatFrame.lua”]:5002: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4666: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:4702: in function `ChatEdit_OnEnterPressed’
[string “:OnEnterPressed"]:1: in function <[string ":OnEnterPressed”]:1>

Locals: self = {
ResetButtons = defined @Interface\AddOns\GSE\API\Storage.lua:616
GetClassIcon = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:51
StartOOCTimer = defined @Interface\AddOns\GSE\API\Events.lua:391
ReportTargetProtection = defined @Interface\AddOns\GSE\API\Options.lua:828
CloneSequence = defined @Interface\AddOns\GSE\API\Storage.lua:14
SplitCastSequence = defined @Interface\AddOns\GSE\API\StringFunctions.lua:74
ObjectExists = defined @Interface\AddOns\GSE\API\StringFunctions.lua:206
GetCurrentTalents = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:96
UnregisterComm = defined @Interface\AddOns\GSE\Lib\CallbackHandler-1.0\CallbackHandler-1.0.lua:153
StopOOCTimer = defined @Interface\AddOns\GSE\API\Events.lua:396
OutputQueue =

{
}
MediaPath = “Interface\Addons\GSE\Media”
inArena = false
PerformOneOffEvents = defined @Interface\AddOns\GSE\API\OneOffEvents.lua:6
DebugDumpButton = defined @Interface\AddOns\GSE\API\Storage.lua:749
GetSpecNames = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:82
GUIConfirmDeleteSequence = defined @Interface\AddOns\GSE_GUI\GUIFunctions.lua:19
CurrentGCD = 0
GSSlash = defined @Interface\AddOns\GSE\API\Events.lua:307
inDungeon = false
UsedSequences =
{
}
PerformPrint = defined @Interface\AddOns\GSE\API\Init.lua:66
ImportCompressedMacroCollection = defined @Interface\AddOns\GSE\API\Storage.lua:217
UnsavedOptions =
{
}
UpdateIcon = defined @Interface\AddOns\GSE\API\Storage.lua:1133
ADDON_LOADED = defined @Interface\AddOns\GSE\API\Events.lua:126
miniMapHide = defined @Interface\AddOns\GSE_LDB\LDBProvider.lua:139
RegisterMessage = defined @Interface\AddOns\GSE\Lib\CallbackHandler-1.0\CallbackHandler-1.0.lua:90
UnregisterMessage = defined @Interface\AddOns\GSE\Lib\CallbackHandler-1.0\CallbackHandler-1.0.lua:153
TranslateSpell = defined @Interface\AddOns\GSE\API\Translator.lua:168
pairsByKeys = defined @Interface\AddOns\GSE\API\StringFunctions.lua:140
SendCommMessage = defined @Interface\AddOns\GSE\Lib\AceComm-3.0\AceComm-3.0.lua:87
UpdateSequence = defined @Interface\AddOns\GSE\API\Storage.lua:634
UnregisterAllComm = defined @Interface\AddOns\GSE\Lib\CallbackHandler-1.0\CallbackHandler-1.0.lua:174
SetEnabledState = defined @Interface\AddOns\GSE\Lib\AceAddon-3.0\AceAddon-3.0.lua:424
isSpecIDForCurrentClass = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:70
ZONE_CHANGED_NEW_AREA = defined @Interface\AddOns\GSE\API\Events.lua:62
DebugOutput = “”
Static =
{
}
ClearCommonKeyBinds = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:127
ClearTooltip = defined @Interface\AddOns\GSE_GUI\GUIFunctions.lua:189
GUI =
{
}
TranslatorAvailable = true
CloneMacroVersion = defined @Interface\AddOns\GSE\API\Storage.lua:30
IdentifySpells = defined @Interface\AddOns\GSE\API\Translator.l

Will say this again. DONT USE THE 2.5.11 GSE RELEASE FOR SHADOWLANDS. There are serious flaws and things MAY work but wont reliably work. Use the 2.6.01-shadowlands-alphax series that is in the link i hit above. This release requires none of the external modification like described in this thread and has all the fixes for Shadowlands that are needed.

Sorry for this,but i cant find the link your talking about,all i can find is the gse for classic and its 2.5.11 GSE RELEASE3

https://www.curseforge.com/wow/addons/gse-gnome-sequencer-enhanced-advanced-macros/files

The stuff in the red circle on this page.

Doesnt work properly for me, imports only work after a put them in a second time and after i restart the game they are gone also i get some lua errors using the most current one “GSE-2.6.01-alpha11-shadowlands”

Thx alot,works perfect now…import also worked fine.

using now the “10” build because strangely enoughe that one works perfectly no errors no nothing

i downloaded the latest alpha… as you suggested… no modifications - it won’t import and when i create a macro, it isn’t saved. Also getting Lua errors. I made no modifications and all three pieces are checked. I downloaded the 11 version… i will try 10

Version 10 works perfect

The whole point of alpha/beta/gamma testing is funnily enough to identify errors.

So what you do is work out exactly what you did to both get the errors and how to replicate them and then you document that at https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues

you dont do anything to get the errors, you just load the addon start the game and they are there

And if they occurred for me, I wouldn’t be asking You to create a ticket on Github with as much detail as you can supply. (I don’t have access to shadowlands but am running alpha 11 on BFA atm.) I am not experiencing what you are so if you actually want me to solve what is affecting you via a method other than telepathy and osmosis …

I should warn that my telepathy is good but not that good.

Ok, I’ll stop doing any suggested changes … real easy for a person that’s not a LUA programmer … and leave the rest of the changes up to you. I only started this thread because of how much I love GSE and wanted to use it in Beta now that I was in Beta. If there is anything as a user of GSE and a player in Shadowlands Beta that you would want me to test and report, I’ll glad do that for you.

Thank You for this wonderful AddOn and the years of fun I’ve had from playing WoW with it.

Watch Reruns of WoW Lazy Macros Creator (Lutechi) Live @ 11PM EST