Something Got Broke and I wonder if it's Blizzard

I don’t know what happened, everything was working fine yesterday but now GSE no longer works. I know Blizzard did some sort of emergency maintenance today.

To share, the GSE window for me opens with no issue but executing the macros by manually pressing the button or using hardware emulation (iCUE) no longer works.

I installed ErrorMonster to take a look if there were any errors, and no errors came up. Debugging looked ok too.

I also deleted my Interface and WTF folders and tried an older version even the one that was built in late September, and to no avail, nothing works.

I tried importing my macros back in fresh, and nothing fires not even an auto attack.

Same here. Was working earlier today.

I’m doing a full reinstall of WOW to see if that fixes it. If not, I think Blizzard did something to their API for spells.

Thats strange mine is still working atm. I’m running a disc priest macro currently but everything seems to be going good.

Full re-installed seemed to fix it. But there is a new console command I hear that also fixes it.

I wonder if this may have something to do with the new thread tim just posted about
ActionButtonKeyDown or ActionButtonKeyUp settings

I think it does, I’m looking at this too on the official forums too.

All the details you need are at ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

1 Like

Thanks Tim for the quick reply. Someone also posted this on another thread and works like a charm:

/console ActionButtonUseKeyDown 1

I get why Blizzard did this update, but Blizzard is terrible at updating addon authors and such.

that command is what the toggle in options does

Ok this is weird but you have to do this every time you logon it seems.

that is something that Blizzard need to fix and is on their list. It should save but for some reason isn’t currently

1 Like

You have saved my life, friendo

1 Like