ToS Patch... Addon no longer works?? :'(

Please fix

Having the same issue

The only version that will not work after the patch update will be the old GS1 client.

This is not supported by Tim. GSE 2.x will continue to work with the patch.

You will need to either upgrade to GSE found on Curse or wait for Semlar on WoWInterface to update the TOC file to make it work for the new patch.

GSE2 works perfectly.

If you are using an old version you are on your own. That may sound harsh but there are a lot of changes under the covers each patch and there is only so much time. The rewrite of 2.0 put a lot of work into smoothing these changes out.

works perfectly for me.
some may also have to check if other addons are causing hassles.

As mentioned above, GS original is affected, but can be resolved by updating the TOC file in the gnomesequencer folder in addons. There are details on this in the comments section on wowinterface for GS. See link below:

http://www.wowinterface.com/downloads/info23234-GnomeSequencer.html#comments

While I think TL has done an amazing job with 2.x GSE, there is still something wonky with the priority sequences. It is not uncommon for it to spam the lowest priority for 5, 10, sometimes 15 GCD’s. There is an open issue on this on the Git repo, but I haven’t seen any updates in this regard.

For whatever reason the original GS handles priority macros properly ~95% of the time, so I have reverted back to it until GSE can resolve its problem with them.

@Scott Davis - I am still trying to replicate the priority issue. Problem is until I can cause it I cant fix it.

I see it on virtually any priority list I can make. For example, take the sample Arms single target one which comes with the base addon, and it will mash Slam, repeatedly (even as a priority macro) when you have rage for MS, or even rage free CS. I’d like to help recreate it so if there is anything I can provide, I’d be happy to.

The problem is that it’s something unique to your PC. I’m not saying that as a copout as Dohram has the same issue but when I take his macro and run it in my rig it behaves. If I take his entire mod set and UI it still behaves.

Can you look into how GSE handles the priority vs. GS? Since GS works, but GSE doesn’t, I’m not sure what about my PC might be affecting it. I use the exact same G key on my keyboard (e.g., identical keypress, repeat time, etc.) and I get wildly different results with the same macro content between the two addons.

I have tried to vary the keypress speed, but it doesn’t seem to have an effect. I ran the GSE debug, and it shows all the abilities off cooldown, but selects the last in the list.

I am constantly looking at it but as I said it works on my pc exactly as it is supposed to. As you said there is already an open ticket for it on GitHub. https://github.com/TimothyLuke/GnomeSequencer-Enhanced/issues/302

0 issues here, working perfectly.

im using the older GS and NONE of my macros are working

I finally found the priority bug. In 2.1.02 its mostly fixed. I have a final fix on Git but need to test it ingame properly. This when its tested will be 2.1.03

Thanks for the diligence in hunting this down. 2.1.02 definitely fixed the priority macros for me. I know it must have been frustrating when many said there wasn’t an issue, so I really appreciate you taking the time to find and fix this.

I’m having an issue too that started yesterday. My macros I write in GSE2 no longer write to my macro in World of Warcraft. For instance, I will type in /macro then make new macro, give it an icon, and save it. Then I will type /gsse make a new macro in gsse with the same name. The icon transfers over, but when I write the actual sequence and save it nothing happens. In /gsse it shows that my sequence saved but under the /macro it is still blank and does nothing when clicked. I’ve tried reinstalling, clearing my cache…etc. It wasn’t that big of an issue until today when I transferred servers. Now I have no macros and can’t make new ones.

Delete the macro you have created manually and use the Create Icon button.

or

Change the macro you manually created to be

#showtooltip
/click [button:2] macroname RightButton; [button:3] macroname MiddleButton; [button:4] macroname Button4; [button:5] macroname Button5; macroname

Replace macroname with your macro’s name.

[quote quote=50018]Delete the macro you have created manually and use the Create Icon button.
or
Change the macro you manually created to be

<table class="crayon-table"><tbody><tr class="crayon-row"><td class="crayon-nums " data-settings="show">
1
2
</td><td class="crayon-code">
<span class="crayon-o">#</span><span class="crayon-v">showtooltip</span>
<span class="crayon-o">/</span><span class="crayon-i">click</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">button</span><span class="crayon-o">:</span><span class="crayon-cn">2</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-e">macroname </span><span class="crayon-v">RightButton</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">button</span><span class="crayon-o">:</span><span class="crayon-cn">3</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-e">macroname </span><span class="crayon-v">MiddleButton</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">button</span><span class="crayon-o">:</span><span class="crayon-cn">4</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-e">macroname </span><span class="crayon-v">Button4</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">button</span><span class="crayon-o">:</span><span class="crayon-cn">5</span><span class="crayon-sy">]</span><span class="crayon-h"> </span><span class="crayon-e">macroname </span><span class="crayon-v">Button5</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-v">macroname</span>
</td></tr></tbody></table>
Replace macroname with your macro’s name. [/quote]

I think that worked. Had to type it in manually. Thankyou so much!

my problem is it works till it doesnt work then I have to reload my UI to get it working again… Does any one have this problem and if so can you list your other add ons… maybe something else is causing the problem… but in my add-ons GSe is red… which means its out of date… even though I have just downlaoded the GSE-2.1.03-Alpha1

GSE Should be two colours in your addon list - red and white. This doesn’t mean its out of date.