Unable to import Macro for my DK

Hey all, I am unable to import any macros for my dk. All other classes and specs work just fine. I import the string and it doesn’t even give me an error. It just does not show up at all. Thoughts? Thanks!

whos macros are you trying to import? also how many macros do you already have? there is a limit on how many can be made.

Sorry I should have offered up more info. I was on my way out the door when I started to write the post. The macro in question was one that was working just about a week ago. It is Griggers Blood DK macro. Also upon further inspection none of my dk macros work at this point. I only have 3 macros for my dk so it should not be a matter of too many.

The macros I have been using are all current. They just stopped working on my dk. All of them lol. I deleted them and have tried to import them again but no luck. This is the only character that I am having this issue on. All of my other toons have working macros. The dk is the only one that has stopped working.

how many total macros do you have? not just DK. that might be the issue, is that you have to many macros. try a diffrent persons macro to see if it works. let us know so we can think of something else to try.

I went through all my characters and checked. I only have 3 at max per character. I do have every class at 120. All of my other macros work on them. The thing that has me scratching my head is that these macros worked about a week ago on my dk. The macros just suddenly stopped working and wont import at all but only on the dk. It has me scratching my head.

when you get a chance, pick someone elses macro and test to see if it works for you. also not sure if you did this (probably did) delete it and re import the one your using.

Yeah I did try a few other macros and none of them import nor do they give an error. I deleted every last macro on the dk and still no go. Maybe I am just not meant to play my dk lol

Watch Reruns of WoW Lazy Macros Creator (Lutechi) Live @ 10PM EST