GSE Cycling but not casting

strange thing happen this issue is no longer happening to me since yesterday I log with all my addons elvui included and the macros works with no problems I don’t have to do the troubleshooting or write the script in chat .

I think bliz fixed something.

ElvUI stopped changing the setting at login.

2 Likes

I can also confirm. I tried all suggestions from Tim and others. The only work that worked for me was the following line:

/console ActionButtonUseKeyDown 1

Works now! Thank god!! LOL

mate this isnt an issue anymore coz the problem was from elvui and it has been fixed.

You are my hero! I just signed up for your patreon.

Downloaded updated GSE today 10.0.2 also have the High Perf Macro Plugin 7.0.3

Had fixed the clicking but nothing running before this. Have done the stubs again and still cycling without clicking on spells. Not sure what to do at this point.

try making the macro stub look like this:

#showtooltip
/click [button:1] MACRO_NAME rightButton t

Also make sure you have cvar keydown selected and action keydown box ticked. Just change MACRO_NAME to your macro’s name.

You should remove this. It hasn’t been maintained since mid legion and will only cause you problems.

You need to go back to this document and work through your UI. ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

Blizzard changed how this works as recently as the last patch and depending on what your other mods are doing and your UI choices you will need to configure GSE to work with that. Making random changes to “I just set x and it worked” won’t help you if you don’t know why making said change is doing anything. This isn’t a “try all the things” this is a case where you have to look at your environment and then make decisions about how GSE is going to operate.

I actually have a very similar issue.

However it only ever happened on my warrior in prot spec.
Fury work well as well as all my other character and specs.

I have been trying to try other macros, reload, relaunch, nothing works.
At start it seemingly works but then Thunderclap start not casting anymore.
And then nothing end up casting at all abilities cycle but doesn’t cast.


While writing I investigated a little more and found out that removing the line:
/castsequence reset=Target Shield Charge, null
in the KeyPress macro variable solved the problem.

For some reason it used to work before but not anymore.

I just added an action block at the start of the macro with the same instead.
Won’t be checked every key press but at least it won’t block the macro anymore.

Hope this can help if you have the same issue…

we are all having a similiar problem…when you get a new car that doesnt work…do you have to overhaul it? from all the people having problems with this, i am surprised some have on their own found remedies …the developer (YOU Mr.Luke) i believe, is responsible for fixing a program related problem which apparently this is… not blame people for “read it and fix it” cures…especially when it seems to be multitudal in essence. dont be so grouchy. We all know you are an expert in this and respect that, but we arent… thats why we depend on you to right things or come up with a clear understanding of how we, no tech. types, can do.

I appreciate what you are saying however there is no way I can tell what every other mod is doingZ. WoW fldetwrmines the load order and GSE will on its first time set itself up to what your UInis configured to however after that if another mod changes the setup there is no way for GSE to know. Hence the troubleshooting tab whereby you can set GsE to which ever mode you are in. This isn’t something Incan code and unfortunately requires people to know some things about your UI. This isn’t unreasonable when you are using a tool designed for people who know how things work.

GSE isn’t designed for amateurs who have no idea how to play a class. And have no idea how macros work. It is a GIGO tool. Garbage in, Garbage out as it expects you know what you are doing.

And using your car analogy - there is no warranty if you don’t know how to drive and use it in a manner other than prescribed. There is a reason why cars come with manuals.

Also Blizzard changed how this works and it is constantly changing. It has changed 5 times in 3 weeks of live let alone the permutations that were in Beta. Blizzards end game is to bring WoW to XBox game pass. As such a lot of things around macros are being made harder to dissuade people from using or depending on them.

2 Likes

i can understand the connundrum being caused and the head ache it is causing… for you and everyone…it frustrating us all and I know youre getting hammered…my intent was not to hammer you… i respect you too much for that… We are all used to having a workable prodct that makes us play better… the frustration is now we dont until we can be re-educated so to speak. its like converting form automatic to stick drive…takes some work. lol as i remember. thanks for your reply and i wish we all could help and solve this together. best of luck.

1 Like

This deleting Icon and creating worked for me! Thank you!

this just worked! :slight_smile:
thanks to you ! :smiley: