💤 Lutechi 9.x+ Fury Macro All-in-One

Welcome to my AIO Macro Series, it covers every possible talent combination. Give this smart lazy macro a try and look for my other classes or specs if you enjoy this one.

Tell me while I stream if it worked for you or ask questions: Lutechi@Twitch

WoW Lazy Macros Discord | Support


Usage Information

Mod:Ctrl - Heroic Leap on Cursor | Mod:Shift - Enraged Regeneration
Auto charge on target.
Have questions or suggestions? Jump on my stream and say hi! :wink:

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.14.

Macro Version 1

Step Function: Priority

KeyPress: Battle Shout, Heroic Leap, Enraged Regeneration

Main Sequence: Raging Blow, Execute, Whirlwind, Rampage, Storm Bolt, Bloodthirst, Victory Rush, Onslaught, Bladestorm

KeyRelease: Heroic Throw, Recklessness, Charge


What TALENTS is this using?

Hello jared,

Just like my protection warrior one, you can pick any talents. It’s for you to decide. Try out what works best for you.

2 1 1 3 3 2 1 funciona bien (editado 22/01/21)

1 Like

Hey @lutechi — nice work. I’d like finer control over my stormbolt. How should I change that massive cast sequence section to remove it? Just delete the instances of it?

Hey Fenriswulf,

Yea, just remove the chunks with that ability in it. If you break the macro, can always reimport it :slight_smile:

I kept it as is but replaced every instance of Stormbolt with a prompt from Rampage. Seems to work really well. On the training dummy I’m matching the sim. Is there any reason not replace it with Rampage as I have done that you can think of?

Also – is this intended to work for AOE as well?

I believe Rampage is the very first one in the priority (not in-game right now to check), so it should fire off pretty fast already without that I think.

However, if Stormbolt was before or in between the others, replacing it with Rampage it might add a delay to the next in line until it is used. If you do not want any extra delay between what exists there, then just remove the Rampage you added.

Gotcha. I’ll have a test and see.

And on the question of how well this works for AOE?

does anyone know why the macro keeps disabling the sound effects? i have sound effects on, but for some reason when i use this macro it disables it.

doesn’t affect the music, just sound effects

Hello Thandim,

check out this reply:

thanks @lutechi i’ll try that

didn’t work. when i went to check it, the box was already checked. seems to be only with this macro, when i try other macro’s i don’t have the problem.

Oh, did you try to uncheck it?

I know it’s a dumb question, but just making sure as others in the past they say it works after unchecking it.

unchecked and rechecked it. tried it both ways

Ok thanks, was just trying to troubleshoot.

I will try to dig in if I can find more info regarding that. If you search for sound or effects in the forums might be able to find something.

Sorry that did not work, hopefully we can figure out your sound or maybe someone can share what has worked for them.

no problem. this is a great macro and thank you for taking the time to help.

1 Like

One thing im thinking off… try to change the sound channels on sound options?

maybe it has something to do, with choosing the soundcard in its tab.


I have the same issue, turns sound off

Hello brad,

Is it happening after using a modifier?

Sorry everyone having sound issues, I play without sound for many years.

I just put music heh.