💤 Lutechi 9.x+ Protection Warrior Macro All-in-One

Welcome to my AIO Macro Series, it covers every possible talent combination. Give this smart lazy macro a try and look for my other classes or specs if you enjoy this one.

Tell me while I stream if it worked for you or ask questions: Lutechi@Twitch

WoW Lazy Macros Discord | Support


Usage Information

Mod:Alt - Revenge use when free procs or spend extra rage | Mod:Ctrl - Spell Reflection | Mod:Shift - Shield Wall
Auto charge and auto taunt per target.
Have questions or suggestions? Jump on my stream and say hi! :wink:

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.15.

Macro Version 1

Step Function: Priority

KeyPress: Revenge, Battle Shout, Spell Reflection, Shield Wall

Main Sequence: Shockwave, Dragon Roar, Demoralizing Shout, Thunder Clap, War Stomp, Shield Slam, Ravager, Victory Rush, Devastate, Storm Bolt

KeyRelease: Thunder Clap, Heroic Throw, Execute, Taunt, Avatar, Revenge, Charge, Ignore Pain, Shield Block

1 Like

What is the Talents for this?

Hello jared,

It’s All-in-One macro, per the description above you can use any talents you wish to try.

You can always modify anything if it works better for you.

It does not charge or do anything until im in combat. Beats the purpose of a charging tank.

Hello Zawdiac,

I think probably Blizzard is not liking you. I understand what you are experiencing, sometimes it would work for me and sometimes it would not due to castsequences issues. Is supposed to be there in the key release I believe, I even tried to do a workaround for it but it seems still having issues.

Do you have any suggestions?

Feel free to modify it and report back if you can improve it and we can all benefit from it.

1 Like

I keep getting this error when I run your script. I’ve tried replacing it but same thing. Other scripts run fine.

Message: [string “UIErrorsF”]:1: ‘=’ expected near ‘’
Time: Tue Nov 10 17:52:06 2020
Count: 48
Stack: [string “UIErrorsF”]:1: ‘=’ expected near ‘’
[string “=[C]”]: ?
[string “=[C]”]: in function RunScript' [string "@Interface\FrameXML\ChatFrame.lua"]:2174: in function ?’
[string “@Interface\FrameXML\ChatFrame.lua”]:5073: in function <Interface\FrameXML\ChatFrame.lua:5019>
[string “=[C]”]: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4737: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010>
[string “=[C]”]: in function RunMacroText' [string "@Interface\FrameXML\SecureTemplates.lua"]:441: in function handler’
[string “@Interface\FrameXML\SecureTemplates.lua”]:654: in function <Interface\FrameXML\SecureTemplates.lua:602>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:266: in function <Interface\FrameXML\SecureHandlers.lua:263>

[string “@Interface\FrameXML\ChatFrame.lua”]:5053: in function <Interface\FrameXML\ChatFrame.lua:5019>
[string “=[C]”]: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4737: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010>
[string “=[C]”]: in function UseAction' [string "@Interface\FrameXML\SecureTemplates.lua"]:345: in function handler’
[string “@Interface\FrameXML\SecureTemplates.lua”]:654: in function SecureActionButton_OnClick' [string "@Interface\FrameXML\ActionButton.lua"]:108: in function <Interface\FrameXML\ActionButton.lua:102> [string "@Interface\FrameXML\ActionButton.lua"]:144: in function ActionButtonDown’
[string “ACTIONBUTTON3”]:2: in function <[string “ACTIONBUTTON3”]:1>


Hello there Mark,

Not sure what all that means or comes from.

Have a few generic options:

  1. Disable all addons but GSE and try again. Try next if did not work.
  2. Delete the macro and reimport. Try next if did not work.
  3. Delete and reinstall GSE either with a tool or manually. Try next if did not work.
  4. Backup WTF first > Delete WTF and try again. Not sure after this.

i play in CN server. if i use English language then it works great. if i use Chinese, some spell can’t be cast, like Shield Slam. i have checked the spell name , they are tranlated correct.

i found the issue, the [equipped:shields,exists] macro can’t be run in CN server.

Im trying to use Lutechi’s AIO Prot Warrior Macro, but it’s breaking for me almost instantly after a single mob. The macro still cycles through abilities on key-press (displaying different abilities) but nothing actually happens. Abilities dont fire.

I had this happen before in BFA. And the issue was macro’s trying to use Neck powers on a character that didnt have them. But I have no clue this time.

It works for the first enemy I fight, then it just auto attacks.