💤 Lutechi 9.x+ Shadow Macro All-in-One

Welcome to my AIO Macro Series, it covers every possible talent combination. Give this smart lazy macro a try and look for my other classes or specs if you enjoy this one.

Tell me while I’m Live if it worked for you or ask questions: Lutechi@Twitch

WoW Lazy Macros Discord | Support


dKu0haqiKuvNsuvAwcDlbLDHKc)csdtuCmqwMK6zqmnsCnKyBsIVjjnoa6CGQ1PcVtG6EcI)HKkgia4GaOfkG6HartKKsxuazJiPuFejvzKcQojjvTsbWljPWmjPYnbc7eq)uuvnuGKLca9ujMkj5QiPsBvG0xrsjVfuUlqTxv9xskAWkDyPwms5XImzrLlt1Mbs9zs1OjLttXRfiMnLUTkA3O(nIHliDCbOLRsphQPtCDKQTlQk(UOkJxu68ijRhjfTFf)qVQhi0xuh1vvGaz4QxnlHdq1MFQLAcq1N)hy9R6lH72qTgoiFrtKqXhOO5rYZ2utQo70LGPgjYjQGAPlEsZeg8WYegwRZrYlSZoDjH1wBygomc7OqvaSk8VOQTol4VaqMQzv1wNLVaq6Ig5(f1rx8KMbauLNrsAFH6vcuq9l2q4hyDLmqFbentVTQNf)Mpolgc)b(lbIbn5MCqsodTLMMXAeQ(a)f16GUPBLhi0xc3TH(fqqYDaqRmByZcW8hOzZZiAZccdNB2I33zBo3SfVVgwFwGgDn5SV(SgqpRQ26S45MaaYR3INdaGYK5epbycq4D(4Zgq6owmegpl5olMUUUJfdHXuNzda9ZqNLWZEs1Sy5695SnNBwCt1SAgQ)SbNVFjO9100So(v9YxkH6j1R2hynfa)ci60Leu)Ineg)QEGqVQhi0xqtnwWEaP7CYNfgtsAnZU1W6rpRbl4itK26SCaHIezI0wNLde0AWZEDSlHi9v3LzNfPgPk84SquuYunolIcCiL4SquuYun4zHXKKwZSBnSE0ZAWcokT1z5acfb8Sxh7sisF1Dz2zrQrQcpolefLmvJZIOahsjolIcCiL4SquuYun4zHXKKwZSBnSE0ZAWcoYePTolhqOiGN96yxcr6RUlZolsnsv4XzHOOKPACwef4qkXzHOOKPACwikkzQ(aR)cAQXc2diDNt(SWyssRz2Tgwp6znybhzI0wNLde0AWZEDSlHi9v3LzNfWmWRJZsbq4bplmMK0AMDRH1JEwdwWhsBDwoqqRbplGzGx)ar(cAQXYSWyssRz2Tgwp6znybdEweekkvQ(av(cAQXYSWyssRz2Tgwp6znybdE26AaRRK5bs5lOPglZcJjjTMz3Ay9yICsRLO0wNLdkOirair)IjxWZw06CK8MfK3gR9aR8f0uJLzHXKKwZSBnSEmroP1s0ZAWcokT1z5Ocke4zvBFYTyiCWZcJjjTMz3Ay9yICsRLON1GfCuARZYrfueWZguIj3SQi3RZYxuhHeQ6mNg5lkFbKKtAT8b(lH7DUN2xa6PG80(sGDR80(caAyDON2xuDnCqCb6P9fvxdhexQFAFrnCQaq36n2FvV8f1WPcuxhJFvpqOVGk9v3fN9tQMfgt067j4hy9xqtnwMfgtsAnZU1W6rMaAY98ac8S1i1vGd4de5lOPglZclP1m7wdRhtKtATepj5IsBDwoqqraplIcecGuEGkFbn1yzwymjP1m7wdRhpj5oARaEwfaZOq5bs5lOPglypG0Do5ZcJjjYjTwIsBDwoQGcbE2RJDjefkZolIcesvL4SmDRn4zHXKKwZSBnSE0ZAWcokT1z5abToYePTolhvqHap71XUeI0xDxMDwef4qkXzz6wBWZcJjjTMz3Ay9ON1GfCuARZYbeksKjsBDwoqqRJmrARZYrfuiWZEDSlHi9v3LzNfrboKsCwkacpolIcCiL4SmDRn4zHXKKwZSBnSE0ZAWcoYePTolhqOirMiT1z5Ocke4zVo2LqK(Q7YSZIOahsjolfaHhNLPBTV8fa0W61pTVuepuQnDojgc)fqDnKRrO6lG66GOtxYR6bc9f0uJLzHXKKwZSBnSEmroP1s0ZAWcokT1z5OgTg8SquQbSYdS(lOPglZcJjjTMz3Ay9yICsRLO0wNLdfueWZckmvjntA2Wj3l5(ar(ckDSplmMK0AMDRH1JjYjTwIEwdwWGNTO15i5bAJZ5E5lGIGfq0Pl5v9YlV8Yl)d

Usage Information

Mod:Alt - AOE with Mind Sear and Searing Nightmare if Talented
Created@100ms

Have questions or suggestions? Jump on my stream and say hi! :wink:

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.01-beta5-shadowlands.

Macro Version 1

Step Function: Priority

Pre Macro: Vampiric Embrace

KeyPress: Damnation, Shadow Word: Pain, Vampiric Touch, Searing Nightmare, Shadowform, War Stomp, Mind Sear

Main Sequence: Mind Flay, Mind Blast, Shadow Word: Death, Vampiric Touch, Devouring Plague, Void Eruption, Shadow Word: Pain

5 Likes

It turns off Sound Effects when this macro is used.
Update: Could be Twitch not updating GSE properly. I’ll be back!

Hey choco, try to play with the options settings in GSE. There is a sound check box in GSE options, see if it makes any difference on or off.

Nope. No difference. Using the macro toggles WoW Sound Effects OFF. I tried another macro and it works fine.

Maybe @TimothyLuke can chime in and might know what it could be. I have heard of a similar issue but I’m not a 100% what is the workaround or fix.

Check your GSE options - it will be there not the macro.

In GSE’s general options look for “Prevent Sound Errors”. Untick that. That worked for me at least.

1 Like

All good now. I tried the Prevent Sound Errors option when I first noticed the problem and it made no difference. However, I jumped on this morning at it’s just fine, so now I can give Lutechi’s macro a go and pick it to pieces.

Just kidding, mate. You’re a legend!

1 Like

For some reason its works through the rotation until Vampiric Touch, then just spams Vamp Touch over and over without looping through mind flay.

No changes made to imported script. Lvl 20.

1 Like

Same here, gets stuck after vampiric touch to often.

2 Likes

I think youre spamming TOO fast right?

Or you could add it separate from its initial macro into another one.

Dunno, try both! :slight_smile:

Cheers

1 Like

Let me know if you guys are able to get it working better.

Tinker with it :wink:

what i told her ; ) yeah man

1 Like

Macro works great, but the ALT Modifier for AoE isnt working. My toon stops casting when i press ALT and loops shadowform on and off. Anyone had an similiar issue?

Macro is working well for me, able to dot things easily with it. It does get stuck in a Vampiric Touch loop sometimes, but a lot of Shadow Priest macros do. My most favorite from early BfA did the same thing and even my edits to it do. Not sure why it happens but it isn’t a new thing. When you see it loop just let off the marco, tap W, and go back to the macro again, not a big deal.

in wow Alt+s might be your Toggle Sound Key Bind. Hit “ESC” and go in “Key Bindings - Miscellaneous” and see if Toggle Sound is Alt-S.

check your wow keybinds. Esc>Keybindings>Action Bar> Special Action Button. I bet alt-1 is your stance change

1 Like

Hey lutechi, i just started lvling shadowpriest 14 now, and for some reason your macro only use SWP and MB and not mind flay I already max hunter with ur macro and it working fine no problem any idea how to fix this ?

Hello Almago,

Not in-game at the moment. Can always click the #2 tab at the top while editing the macro to create a backup and then go back to the #1 and edit.

Try to remove spells that you do not have yet (they are in red color in GSE editor). Might have to do a few times depending as you level up.

Hopefully, that works for you.

1 Like

will try that out ty