💤 Lutechi 9.x+ Unholy Macro All-in-One

Welcome to my AIO Macro Series, it covers every possible talent combination. Give this smart lazy macro a try and look for my other classes or specs if you enjoy this one.

Tell me while I stream if it worked for you or ask questions: Lutechi@Twitch

WoW Lazy Macros Discord | Support


dOe4gaqiqvvNcufMLkDlqLDbPKFrsddqhdv1YaLNjctdOUgQSna8nGmoj05KuRtI6DKG7js0)avjduKshKezHIu8qufMOiHlcc2iOQ0hbvvgPivNevjResvVesrZee6MsGDkj)uKKHcqTuqv0tf1ufrxfvP2QiPolOQ4TkYDvu7vv)fsPgSshwyXqYJrzYGOltzZsqFwfnAionPEnQIMTc3gHDt1VHA4QWXjrTCe9CKMoX1bPTdPY3biJNe68sK1dQsnFif2Vu)8)KFf)pdrENec8iDEH28Uk9ubr4dAReVs1xb7t(50TXXq788ZiICqlRQcimGgb8UerWiXu0IHjuf1buXyiA4QHdiCqDe8OeCebJedxmgWPD4WUPYheq(8)CYyyUq)SsEPEtgdZLpReubbt(zicvmgIoTjbKwyiFg(LHqQnsQg7Ffmaac6Zfeo0yWlxms0zUOX(NMpdbVqmjZ4bM4iKaLEOLsFA(CkScdOd5R4)50TXXNladzzLgsVW1RsPcc9ciTG0leo0qAeAwVHdzV5GrQluZ0XOxahmPx0an6TamKLZi6cLEHR30Ty0lG0csVPWcbP3SqQ5P1OhWM0BavW9guQMk9Ij79iOun6SE1f2RJ7vcYttqRg98G0cXGmT8bcKG2Op9aDwVkd1OIg70EXK9sHEEAurJDk8Qx0dL4OxS3lrPEPcPfe9goK9sJs9IOH)9Qa84ZPoi1bQHr)KV858HX4vk(kyCW(CbbJeNAJKQXo9t(v8)KFf)pRYcQqnLHAoZ6DYXmKWDBO9ZldtGkK7HjxcmKLJHm3BcyG4abwHENCmdjC3gA)8YWeOc564dtM7fmaCfbRqVtoMHeUBdTFEzycuHCpm5AkQPcDUxasWbaWVc2Nvzbv6DYXmKWDBO9ZldtGkKRedZLYWutCnf1uHo3lF(C1fR)QeFwLfuP3jhZqc3TH2pVmmbQqUsmmxkdwnX1uutf6CVjaNawn4Vc8NvzbvOMYqnNz9o5ygs4Un0(5LHjqfYvIH5szqQjM7fgioaQRV9YBhbpk1RsuAaDik07KJziH72q7NxgMaviZ9cdeha11Ff3NvzbvOMYqnNz9o5ygs4Un0(5LHjqfYvIH5szqQWM7fCnmGa8va8zvwqLENCmdjC3gA)8YWeOc5sGHSCmK5EHbeuc(GuO3jhZqc3TH2pVeyiltr0fkZ9cUUUUOc9o5ygs4Un0(51uutf6CVGbXbM)xb6ZQSGkutzOMZSENCmdjC3gA)8kXWCPmmvyZ9sAutsPeKNM0BVGaXbI72BrUAWfV9YXbSg4TxooG1avO3jhZqc3TH2pN7L0OMKsjipnP3EbbIde3T3IC1GlE7LJdynWBVCCaRbE7LJdynWBVf5Qbx82lhhWAG3E54awd8Rk(zvwqLENCmdjC3gA)8M2JruYiVmmbQqM7fCcyaW9v1FwLfuP3jhZqc3TH2pVmmbQqUsmmxkNqnX1uutf6CVkrpqkPOoe7ZqeJpGOMqlF(ZagtLccgj(t(YNrtReGjnk9t(v8)SQeKNMyUruQ3jhJeKeZFfSpREysisW4zVthMCrcsI5VkXNvpmjOunv6D6WKlsqsm)vG)S6HjhbLQrN17KJrcsI5VI7ZQujiLqKGXZENCmdtGkK5VcGpRYcQ07edtGkK7HjZ9cge4IW(kqFwLfuP3jgMavi3dtM7fmiWau8LpZdmbQq(085SyhWxOot0y)ZztzOMl6y8zatAfems8N8LpJMwj4PnSGAFYVI)NvzbvOMYqnNz9o5ygs4Un0(51uutf6CVKg1Kukb5Pj92l4AoqaC71HogV8YlV8Y)a

Usage Information

Mod:Alt - AOE with Epidemic and Sacrificial Pact | Mod:Shift - Heal with Death Strike
Pet auto assist or passive if no target.
Created@100ms
Have questions or suggestions? Jump on my stream and say hi! :wink:

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.07.

Macro Version 1

Step Function: Sequential

KeyPress: Leap, Claw

Main Sequence: Sacrificial Pact, Summon Gargoyle, Unholy Blight, Raise Dead, Festering Strike, Death and Decay, Epidemic, Outbreak, Apocalypse, Death Coil, Dark Transformation, Death Strike, Soul Reaper, Scourge Strike

KeyRelease: Death Grip

3 Likes

unable to import for some reason

Hello zashisouthpaw69, what version of GSE you are trying to import with?

I can’t find why, but macro insists on equiping Legion’s Artifact Apocalypse instead of casting the spell.

Hi Uldred,

Yep it’s a Blizzard game thing (bug) because of Apocalypse. Workaround is leave those weapons at home in the bank lol. Sorry have not found anything better yet.

When using Necrotic Strike would you replace Scourge strike with it in your macro

Man, what talents did you use?

Cant drag the icon and no inner loop limit?

I like this one a lot but I am having an issue I’ve never come across before. As soon as I get close to 3k dps, I get disconnected from wow. I went into the macro and took out the asphyxiate cast because it was the only thing that was in white text and I hadnt speced it. Went back over to the dummy and i didnt get disconected but I also stayed about 500 away from 3k dps. So i then put the asphyxiate cast back in and actually took the talent and I ended up getting disconnected at 3k. My internet is not the problem but I dont understand what is causing it either, any help would be greatly appreciated. my talents are 12?2321. I am also using elvui, console port, and xbox one elite controller.
edit: tested longer and i am having the issue whether asphyxiate is in the macro or not. so i dont know what is up. happens very quickly tho

Hello @Gnaargh,

What speed are you pushing the button at?

I have not experienced this kind of stuff in many years.

Usually it was because the MS speed of pushing was too fast.

hey, im not sure. im using reWASD in conjunction with console port to play with a controller. reWASD has a setting where i can set the trigger speed as keyboard native, fast, slow or do not repeat. I have it set for fast and it has not been problematic in the past but ill try a different setting. i have a programmable corsair keyboard so maybe i can set it’s speed and then select keyboard native. i am taking a break for a few before i try and troubleshoot this again so i dont get frustrated. i was thinking along the same lines as you because your macro was firing off a lot faster then others. although i have used some of your other class macros without a problem so i dont know for sure yet. i will change the setting, test it out and see if slowing it down solves the issue.
thanks.

just tested it and got disconnected. i guess ill go line by line and see if tailoring it to my specific build by getting rid of what i dont use helps.

Maybe is a mod causing it? Try to disable all addons but gse and try again. Then GSE and a meter and try again?

What MS again?

yeah, i tried all that. i ended up editing the keypress block to
/cast [nopet] Raise Dead
/cast [mod:alt] Apocalypse
/castsequence reset=target Outbreak, null

and premacro to /petattack
and keyrelease to /targetenemy [noharm][dead]
and sequence to
/castsequence [nochanneling,combat,pet,mod:alt] Sacrificial Pact; [nochanneling,combat,nopet] Raise Dead; [nochanneling,combat,pet,exists] Dark Transformation
/castsequence [nochanneling,combat,talent:7/3] Apocalypse, Unholy Assault; [nochanneling,combat] Apocalypse
/castsequence [nochanneling,combat,talent:7/2] Summon Gargoyle
/cast [nochanneling,combat,mod:alt] Epidemic; [nochanneling,mod:shift] Death Coil; [nochanneling,exists] Death Strike
/castsequence [nochanneling,talent:2/2] reset=target Outbreak, Festering Strike, Scourge Strike, Scourge Strike; [nochanneling] reset=target Outbreak, Festering Strike, Scourge Strike, Scourge Strike, Scourge Strike, Festering Strike, Scourge Strike, Scourge Strike
/cast [nochanneling,@player,combat] Death and Decay

im not done yet with the sequence, but this stopped the d/c so far. ill be adding back the rest of your sequence portion because whatever the problem was seemed to be with the keypress block

thank you for getting back to me.

1 Like

Not a problem, so it sounds like maybe the pet part might be causing the issue.

That might be a good solution/workaround for what you did. :slight_smile:

1 Like

I thought I was the only one with me I didn’t disconnect but my game started to slow down as if I have a serious lag.

Can you share your xbox setup in-game?

I noticed too, but not only on DK on everyclass that has pet of someform ( hunters, priest, mage )

And other thing very strange, im noticing a very noticeable drop in FPS everytime i put on a macro /petattack too.

:expressionless:

2 Likes

yeah. here is what i use for wow with a controller.

  1. Download reWASD and a wow config found at the reWASD web site. Install and load a wow config. This is what is going to convert your controller into a mouse and keyboard; letting you also have the ability for a one button macro tied to your right trigger and/or right bumper. Your left trigger and left bumper are the modifiers allowing for all your skills to be bound. However modifiers within a lazy macro wont work because of this so I usually take them out and bind those skills separately. You can leave them in the macro, however.

  2. Install the addon, console port. this will give you an actual controller layout in game. Make sure you calibrate your controller when prompted and set a controller layout. it has its own menu, action bar and keybind system. so it may conflict with some ui’s. but i have had no issues with elvui.

  3. ElvUI from tukui. I use REDTUZKUI which can be found on tukui along with a host of other custom profiles.

  4. GSE addon with a lazymacro

  5. REtabBinder addon for pvp. select ‘always allow’ when prompted by consoleport otherwise it won’t work. this is so you don’t tab target pets or npc’s in pvp situations.

  6. You are now able to use a controller for all in game content. You can enable or disable some options in consoleport for quality of life issues. For example I go into the advanced options and change “nameplates always on” to ‘true’ and disable interacting with npc’s with the action button. Otherwise I can’t jump around like a crazy person in town without constantly interacting with any npc’s near me. The jump button and action button are the same button.

2 Likes

it was my error fixed and thank you for the response