SHIFT Mod key not working

So, not sure what’s happening but since the last patch to WoW and the latest GSE the SHIFT macro won’t fire if SHIFT is set as the modifier key for moving spells on the action bar when it’s locked. On top of that for whatever reason (sure it’s a mod or something) WoW will not save NONE as a modifier for locked action bars so have to change it every time I /reload or GSE won’t work correctly. It’s odd because I can see it cycling through the spell it’s supposed to be firing when I hold down shift but it won’t fire off.

Troubleshooting steps I’ve taken thus far include “Clear Keybinds”, “Update Macro Stubs”, and “Clear Spell Cache”. Nothing affects it other than changing the default modifier to none. I have also tried unlocking the action bars but it still resets the modifier in WoW to SHIFT and won’t allow GSE to fire despite the action bars being unlocked and the modifier greyed out in the WoW client.

make sure you go into every, and I mean every spot in keybinds and make sure they are not being used somewhere. You would be shocked at the places shift mod gets used. Also certain addons will use the mods also. try disabling addons, and see if it is an addon causing the issue

Yeah, I’ve checked and rechecked. I can’t figure out what is re-enabling it but it’s definitely the shift to move locked actionbar items that is blocking it. As soon as I disable that it works till Blizz re-enables it on reload/zoning/relogging.

Are you using elvui?

I am, I checked there for the actionbar unlock. There isn’t an option that I can see for a modifier for the actionbar. It seems it’s something in there. I disabled it and it’s working fine now. I’m using bartender4 for actionbars and elvui for everything else and it seems to be ok with that combo.

Question, are you by chance using a @cursor, example /cast [mod:shift,@cursor]? I have the actionbar settings enabled but only ever run into issues with @cursor

No, it was for any of the shift mods. This one in particular was for Frenzied Regen on my bear druid. But it didn’t work on any of my characters or any of their mods like my shaman for his AOE modifier.

Alright, the issue i am running into just must be me :frowning:

there something in Elvui that is causing the issue. i wish i could tell you what it is, but i dont have the issue of Shift not working when i am using my Elvui. but alot of people have had to delete the addon or turn it off to get the macros to work right. if by some chance you do find what in Elvui is causing, please let us know.

Turn off action targeting in your UI options.

Look for “action bar lock” in both ElvUI’s keybindings and WoWs. Elv rebinds this to shift every time you login so have to unbind it every time to login. For me this was the straw on the camels back - dumped Elv and gavnt had an issue since. Also got back 30fps and shorter loading times.

1 Like

I’ve disabled ElvUI and gone back to base Blizz bars. Seems to be working much better. Thanks for the info. It seemed to work with Bartender OK as well but since default bars have pretty much all the same functions I just went native.

If you miss Elvui go get “Tukui” it also works just fine and plays very well with GSE and the blizzards default settings in the option for the whole lock bar issue, and plus… its lightweight so not as heavy eating on the game resources like Elvui is.

1 Like